2 verschillende php versies op een mac?

Hi,

Nu PHP 5 uit is wil ik daar graag mee gaan testen.
Maar, ik wil mijn oude php versie behouden.
Is het mogelijk om twee php versies op een mac te draaien?

PHP is een module die 'draait' in je webserver, Apache. De module is een apart bestand en in de apache configuratie-file (de standaard file staat in /etc/httpd/httpd.conf) wordt met 2 regels eerst de module aan apache toegevoegd en daarna wordt de geladen module gekoppeld aan een extensie, bijvoorbeeld .php .php4 of .phps.

google eens verder op php5 php4 en/of kijk eens op bijv.

http://www.webservertalk.com/message317590.html

Hoe dan ook, tot je ergens een kant en klare installer vindt, zal je toch wat moeten unixen in de Terminal…

[quote:a4554dead4]daarna wordt de geladen module gekoppeld aan een extensie, bijvoorbeeld .php .php4 of .phps. [/quote:a4554dead4] Dus je installeert gewoon die 2 modules in verschillende folders, koppelt php5 aan je php5 interpreter en php/php4/de rest aan je php4. Zul je wel manueel moeten in doen in je httpd.conf.