Airport Express doesnt join network thru WiFi

Hi, I’ve set up a network with a Time Capsule. My Mac is connected with ethernet, as are two airport express stations.

A third one (to connect to the stereo) I want to join my network wirelessly. Previously this worked like a charm. But now just doesnt work:

  1. it sees ‘Other W-Fi device (1)’ in Airport Utility
  2. I select it and the I get these messages:

a. preparing
b. examining Base Stations in your network
c. joining Airport Express
d. examining base Stations in your network

but then I keep getting this message:

“an unexpected error occurred. Try again”

What’s happening here? Is it interference??

I have already installed the latest 2Tb model of time capsule.

Time Capsule 802.11n (3rd Gen), OS X Mountain Lion (10.8.5)

Je mag hier gewoon je vraag in het Nederlands stellen hoor.

Model of Airport Express? If it is an Airport Express you plug directly into the power outlet, Apple no longer supports configuring these devices with iOS 6 or Mac OS X 10.7/10.8. You could install the older airport utility on your OS X 10.8 Mac to configure them regardless

Latest model Airport Express: Have you tried a factory reset of the Airport Express?; http://support.apple.com/kb/HT1450?viewlocale=nl_NL