Big Sur: Woorden worden verkeerd aangevuld

Hallo allen,

Er gebeuren vreemde dingen op mijn Macbook. Gekmakend is het. Terwijl ik aan het typen ben, en dit gebeurt in diverse programma’s, dus het is een OS ding, worden woorden op een vreemde manier aangevuld.

Als ik bijvoorbeeld de naam Chantal probeer te typen, wordt dit automatisch veranderd in Chantahal of iets anders. Als ik Adobe wil typen maakt hij er Adobedob van.

Ik heb allerlei instellingen geprobeerd, ik heb spelling controle uit staan. Maar niks werkt. Iemand een idee? Ik kan er niets over vinden.

Schermafbeelding 2021-06-04 om 09.39.30

Alvast bedank!

Wel vaker blijkt in macOS ‘uit’ helemaal niet ‘uit’ te zijn.

Maar je kunt de volgende twee commando’s in Termnial proberen:

  1. defaults write NSGlobalDomain NSAutomaticSpellingCorrectionEnabled -bool false
  2. defaults write NSGlobalDomain NSAutomaticTextCompletionEnabled -bool false

Daarna even uitloggen of herstarten.

Als je de originele instellingen weer wil herstellen, typ (of kopieer) je hetzelfde commando, maar vervang je false even door true

Ik denk dat de namen wel voldoende duidelijk zijn over welke instelling je ermee uitschakelt.

Super, bedankt Night!

Maar heaar helaas, ik dacht dat het werkte, maar zie hier, het is nog steeds niet opgelost :frowning:

Ook na herstart niet? :thinking:.

Nee helaas. Bizar toch?

Behoorlijk

Helaas kan ik ook op het internet verder niets terugvinden dat anderen hetzelfde probleem hebben :frowning:

Kun je bij ‘Automatisch op taal’ nog kiezen voor een taal?

Verder kun je deze nog even proberen:

De naam van de AppleSpell service wijzigen door er .disabled aan toe te voegen, en dan de spelling service geforceerd afsluiten:
sudo mv /System/Library/Services/AppleSpell.service/Contents/Resources \ /System/Library/Services/AppleSpell.service/Contents/Resources.disabled
Gevolgd door
killall AppleSpell

Daarmee wordt de gehele spellingscontroller buitenspel gezet.

Maar je kunt ook terecht bij Systeemvoorkeuren → Toetsenbord → Tekst ). Daar is als het goed is een checkbox met “Correct spelling automatically”. Uitvinken om AppleSpell te stoppen.

Bedankt Nightight, maar helaas nog steeds niet :(. Zie de fout in je naam :wink:

Ik ben bang dat ik een clean install moet gaan doen.

thanks anyway!

Wat staat er bij Systeemvoorkeuren → Taal en regio → Voorkeurstalen?

Schermafbeelding

Schermafbeelding 2021-06-08 om 13.32.02

Gewoon NL