CSS ellende

Geinspireerd door [url=http://www.csszengarden.com/?cssfile=/046/046.css&page=1]css Zen Garden[/url] probeer ik pagina's op te maken met css. Wat ik nu vaag vindt is dat de pagina wel laadt in Safari, maar in geen enkele andere browser (IE, Mozilla, Opera). In Mozilla en IE krijg ik de source te zien en in Opera de content zonder opmaak... Weet iemand waar dit aan ligt???

testpagina

In Camino zie ik inderdaad alleen code, en in Safari de gewenste pagina... Strange indeed :?

Maar waarom is het xhtml??

[i:a171ddfc5c]<meta http-equiv="content-type" content="text/html;charset=ISO-8859-1"/>[/i:a171ddfc5c]

Je gebruikte toch xml?

[i:a171ddfc5c]<link href=“2e.css” rel=“stylesheet” media=“screen”/>
<style type=“text/css” media=“screen”></style>[/i:a171ddfc5c]
Waarom begin je een <style> terwijl je er al een van buitenaf laadt?

@Deskman: [url=http://www.alistapart.com/articles/betterliving/]Better Living Through XHTML [/url]

Als ik een nieuwe xhtml pagina aanmaak ik GoLive staat daar automatisch deze code boven:

<?xml version=“1.0” encoding=“ISO-8859-1”?>

Haal ik die code weg zodat er alleen nog:
<!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd”>
<html xmlns=“http://www.w3.org/1999/xhtml”>
staat, dan ‘werkt’ het wel…

@WebJ: het werkt idd ook zonder die extra regel, maar ik denk dat GoLive die code genereert als ik een .css aan een pagina koppel, want ik heb 'm er niet in gezet…

Wat een gedoe zeg... heb het gevoel of ik weer voor het eerst een site in elkaar zit te prutsen. Onverklaarbare verschillen in diverse browsers, blokken die er soms wel, soms niet zijn etc... Misschien toch eerst maar es een goed boek lezen over CSS... :oops:

Als, je dan toch gaat lezen... http://www.zeldman.com/dwws/