Dreamweaver links foutief op Chello homepage

Ben onlangs met DW MX2004 begonnen. Begonnen met File - New - Category: pagedesigns (CSS) - Twp-column Left Nav en vandaar verder gegaan. Wanneer ik op http://localhost/ kijk ziet het er als bedoeld uit. Upload ik alles naar members.chello.nl gaat het mis. De links kloppen niet. Heb wat manueel gewijzigd maar dat is natuurlijk niet de bedoeling.. Wellicht dat het feit dat index.html in de root staat en de andere pagina's in een subfolder daarvan ook niet echt meehelpt.

Ben er vrijwel van overtuigd dat het probleem in de instellingen welke bij “Manage Sites” worden gedaan de oorzaak zijn.
DW moet toch aan de hand van je instellingen het pad naar andere pagina’s en plaatjes automatisch aanpassen??

In het activiteitenoverzicht van Safari zie ik bv http://members.chello.nl/images_small/copper.gif
Dat zou moeten zijn http://members.chello.nl/e.lebaron/images_small/copper.gif
Kan het probleem er in liggen dat als hostname voor de webserver wordt opgegeven members.chello.nl, dat DW dit voor het produceren van de juiste link aanduidingen wellicht ziet als de root maar dat de files aan de hand van m’n gebruikersnaam en wachtwoord in http://members.chello.nl/e.lebaron/ worden gezet?
Heb van alles geprobeerd maar kom er niet uit.

Index.html en de stylesheet staan in de local root folder.
De andere pagin’a in een subdirectory daarvan (“en”).
De Nederlandse versie moet uiteindelijk in de “nl” subdirectory van de root komen.
Maak ik in de index pagina een link naar een andere pagina (welke in de “en” folder staat) dan zet DW er een slash voor.
Selecteer ik dan vanuit de index deze pagina, dan krijg ik http://members.chello.nl/en/electronics.html
Dat moet http://members.chello.nl/e.lebaron/en/electronics.html zijn.
Haal ik de slash weg, dan wijst ie wel naar de correcte pagina.
Maak ik een link op de pagina’s welke in de “en” folder staan dan zet DW er standaard weer een slash voor terwijl dit …/ moet zijn zoals hier: …/en/aviation.html
De links maak ik door de html file uit het Files panel naar het Link tekstvak van de Property inspector te slepen.

Hoe moeten de instellingen zijn om DW automatisch de juiste links te laten produceren??

Zie http://members.chello.nl/e.lebaron/

Probeer eerst eens alles up te laden met transmit oid. Dan weet je iig waar je het probleem moet zoeken.

Wanneer ik met Cyberduck kijk wat er op m'n homepage ruimte bij Chello staat is dat hetzelfde als wat ik in DW in het Files panel zie. Ben er redelijk van overtuigd dat het in de instellingen van DW moet zitten en denk nog steeds dat het feit dat ik als FTP host members.chello.nl moet opgeven terwijl de site op members.chello.nl/e.lebaron/ staat de foute links geeft. Vraag me af hoe andere DW + Chello gebruikers de instellingen hebben in "Site definition". Bedankt voor het meedenken.

mijn eerste gok is dat je[b:64c09eb443] /xxx [/b:64c09eb443] urls gebruikt en die gaan altijd naar de root. Ofwel ze slaan jouw map (/e.lebaron/) op de chello server over. Dit probleem blijf je houden als je op een server niet direct in de root kan draaien.

bijv: <a href="/paginaatje>link</a>
ipv bijv: <a href="…/paginaatje>link</a>

Van
<img src="/images_small/copper.gif">
moet je dus
<img src="…/images_small/copper.gif">
gaan maken

In dreamweaver kan je (als je het betrefende linkje gaat maken) kiezen of je een absoluut of relatief pad wilt maken. Kies dan voor relatief.

Jack4ya je hebt volkomen gelijk. De voorbeelden welke je noemt, das de manier waarop ik ze momenteel manueel wijzig. Ben nog eens gaan zoeken naar de keuze mogelijkheid om links relatief of absoluut te maken. Naast het Link tekstvak in de Property inspector heb je een "Point to File" symbool en een "Browse for File" symbool. Wat ik tot nu toe heb gedaan is vanuit de Files panel de beoogde link naar het tekstvak gesleept. DW stelde geen vragen en maakte er op zijn manier een link van (welke dus foutief was). Zojuist de "Browse for File" gebruikt. Dan vraagt ie wel of de URL relative to Document of to Site moet zijn. Kies ik document, dan geeft ie de correcte link (bv. ../testpages). Relative to Site gaat fout (/testpages). De "Point to File" methode werkt ook goed. Zal wel het door jou genoemde relatieve pad geven. Het slepen van een pagina welke in een andere map staat gaat nu ook goed!!! Wanneer ik een link maak met "Browse for File" en relative to Document gebruik, dan lijkt het alsof DW dit voortaan ook voor de andere link aanmaak methoden gebruikt. Net even getest met andere links naar andere mappen en het klopt. Gewoon 1 X de "Browse for File" methode gebruiken en het gaat goed. Hartelijk dank!

Heerlijk toch ... die eenvoud ;-)

[quote:053b225557="R_van_Heukelum"]Heerlijk toch ... die eenvoud ;-)[/quote:053b225557]

Tja ieder zijn probleempjes toch?

[sub]Maakt niet uit of je een internet guru of internet newby bent. Een probleem is altijd een probleem. Groot of klein bestaat niet. Een probleem staat namelijk altijd binnen het referentiekader van de “probleemhebber”.[/sub]