Geen password meer bij installatie

Hoi allemaal,

is het mogelijk om een terminal hack of iets uit te voeren zodat je NOOIT MEER je password hoeft in te voeren bij het installeren van programma’s of dergelijke. Ik word er gek van. Ik moet ongeveer 200 plugins installeren en bij iedere installatie moet ik verplicht mn wachtwoord invoeren. TouchID staat apple dan niet toe.

Ik snap dat het veiliger is etc. maar ik weet wat ik installeer en ik geef toestemming, anders had ik er nooit op geklikt in the first place.

Bedankt!

https://youtu.be/VuqZ8AqmLPY

 

Hoe het tij kan keren. ?

Hahahaha geweldig :stuck_out_tongue:

Precies zoals ik Catalina ervaar - Één grote ergernis van betutteling en het doet mij geloven dat mijn rechten als gebruiker steeds meer worden ingeperkt, totdat MacOSX straks gewoon een slap aftreksel is van het nog steeds veel te gesloten iOS.

Zo kunnen we er straks allemaal al vast aan gaan wennen…

allemaal overstappen naar Debian Buster met Cinnamon desktop :slight_smile:

<p class="cite">fred44nl op 22 oktober 2019 om 11:05</p> allemaal overstappen naar Debian Buster met Cinnamon desktop:)
Wie weet misschien ooit als het verder ontwikkeld is :)

@polansky: wel gek dat er geen hacks voor zijn, je zou zeggen dat dit wel op te lossen is door een simpel terminal pseudo maar volgens mij spendeert Apple veel tijd om dit soort “tweaks” te beperken.

Vóór Sierra kon je in het security venster van systeemvoorkeuren drie download opties kiezen:

App Store

App Store plus bij Apple bekende ontwikkelaars en:

Overal

Ná Sierra is de laatste optie “verdwenen” (maar niet heus)

 

Typ in de Terminal het volgende in:

sudo spctl --master-disable

Druk return in en typ je wachtwoord in.

De “overal” optie is nu terug en is gelijk geselecteerd. Gatekeeper zou dan ook moeten zijn uitgeschakeld.

Hopelijk helpt dit. Wil je het weer verbergen dan wordt het:

sudo spctl --master-enable

<p class="cite">polansky op 22 oktober 2019 om 10:40</p> Precies zoals ik Catalina ervaar – Één grote ergernis van betutteling en het doet mij geloven dat mijn rechten als gebruiker steeds meer worden ingeperkt, totdat MacOSX straks gewoon een slap aftreksel is van het nog steeds veel te gesloten iOS.

Zo kunnen we er straks allemaal al vast aan gaan wennen…


Dat iOS gesloten is kan ik mij nog voorstellen. Tenslotte is de kans dat je een telefoon verliest ietsje groter dan een desktop computer. Enige beveiliging tegen ongeoorloofd gebruik vraagt in het geval van een telefoon (of iPad) wel wat extra’s. Maar ik ben er ook altijd op tegen geweest dat OS-X hebbelijkheden ging krijgen die onder iOS misschien werken maar minder tot helemaal niet op een desktop.

@Hendrik IJzerbrood, mijn dank is groot voor de Terminal shell code.
Je moet het maar weten!

verwijderd.

Nee, de derde optie laat zich bij mij (Mojave) ook na het terminal-commando niet zien.

Bij mij (high sierra) dus wel. Krijg je geen foutmelding? M.a.w: is het commando goed ingetypt? Op deze site staat:

sudo spctl - -master-disable

Maar die twee eerste (min)streepjes heb ik nu ingetypte met een spatie ertussen want anders zie je hier op de site (althans bij mijn browser) één iets langere streep staan. In het commando hoeft die spatie dus niet maar moet je kennelijk wel twee mintekens intypen.

 

Het artikel is overigens uit 2016 dus misschien werkt het nu niet meer. Als je in de Terminal man spctl intypt krijg je de syntax te zien van dit commando. Misschien helpt dat want als het commando zelf nog bestaat onder Mojave moet het gewoon werken.

<p class="cite">hendrik ijzerbroot op 22 oktober 2019 om 14:23</p> Vóór Sierra kon je in het security venster van systeemvoorkeuren drie download opties kiezen:

App Store

App Store plus bij Apple bekende ontwikkelaars en:

Overal

Ná Sierra is de laatste optie “verdwenen” (maar niet heus)

 

Typ in de Terminal het volgende in:

sudo spctl –master-disable

Druk return in en typ je wachtwoord in.

De “overal” optie is nu terug en is gelijk geselecteerd. Gatekeeper zou dan ook moeten zijn uitgeschakeld.

Hopelijk helpt dit. Wil je het weer verbergen dan wordt het:

sudo spctl –master-enable


Dit werkt ook in Mojave, dit was het eerste wat ik heb gedaan bij de aanschaf van mn Macbook haha. Echter helpt dit niet met de password intypen helaas, maar wel handige tweak :slight_smile:

Er schijnt een simpele “workaround” te zijn die er in ieder geval voor zorgt dat je geen wachtwoord hoeft in te typen. Er wordt nog wel om gevraagd maar dat venster kun je gelijk sluiten. De truc is om in systeemvoorkeuren je wachtwoord te veranderen in niks. Dus het tekstveld waar je normaal gesproken het nieuwe wachtwoord invult laat je leeg. Feitelijk heb je dan je Mac geconfigureerd zonder wachtwoord. Niet perse wijs maar wel handig als het dus een tijdelijke situatie is die later dus hersteld wordt.

Een andere ‘work-around’ is het wachtwoord eenmalig in te typen in bv textedit of een lege Finder-map, alles selecterren en ⌘ C. Bij Iedere keer dat je je password moet invoeren druk je dan gewoon op ⌘ V. Nog even Enter geven en klaar. Gaat 100x zo snel, vooral als je een wat lastiger wachtwoord hebt.

Maak een password wat zich heel makkelijk laat typen. Wat dus helemaal niet wil zeggen dat het makkelijk te raden is.

 

Maar je kunt toch nog steeds het gebruik van een ww uitzetten? Zit ff niet bij een Mac, dus kan het zelf niet checken.

Er staat me iets van bij dat dat al sinds High Sierra niet meer kan; een leeg password. Maar ik kan me vergissen hoor

Het kan hoor. Ik heb HS en als je een leeg wachtwoord wilt instellen wordt er gevraagd of je het zeker weet.

Ja hoor, ook op Mojave kan je gewoon werken met een leeg wachtwoord-veld.

Wacht, het kon niet meer bij een verse installatie, dat was het. Naderhand dus wel gewoon.