gnuplot

Heeft iemand hier al gnuplot gebruikt? Heb dit geïnstalleerd (en ook AquaTerm) maar als ik gnuplot opstart en bijvoorbeeld "plot sin(x)" doe gebeurt er gewoon niets... Ik heb scripts die ik moet gebruiken om data te evalueren die hiervan gebruik maken, maar zit dus voorlopig een beetje vast. Weet iemand raad?

Pib

Ehm, bij mij werkt het prima. Ik heb beide via Fink geïnstalleerd. Als jij het ook via fink hebt geïnstalleerd moet je misschien even updaten, in oudere versies van de aquaterm-package zat een installatiefout. Als je het anders hebt geïnstalleerd, leg dan even uit hoe, misschien kan ik helpen.

[quote:2993d69b31="Tammo80"]Ehm, bij mij werkt het prima. Ik heb beide via Fink geïnstalleerd. Als jij het ook via fink hebt geïnstalleerd moet je misschien even updaten, in oudere versies van de aquaterm-package zat een installatiefout. Als je het anders hebt geïnstalleerd, leg dan even uit hoe, misschien kan ik helpen.[/quote:2993d69b31] Ik heb beide gedownload als dmg, utigepakt en installer uitgevoerd... - [url=http://www.versiontracker.com/dyn/moreinfo/macosx/1849]gnuplot[/url] - [url=http://aquaterm.sourceforge.net]aquaterm[/url]

Pib

Probeer het volgende eens in gnuplot: [code:1:b6730c030c]set term dumb plot sin(x)[/code:1:b6730c030c]

Als het goed is zie je nu een (erg provisorisch) plaatje van een sinus, dat aantoont dat gnuplot op zich wel werkt.

De volgende test is natuurlijk

[code:1:b6730c030c]set term aqua
plot sin(x)[/code:1:b6730c030c]

Suggestie wat er ook nog mis zou kunnen zijn: de [i:b6730c030c]environment variable[/i:b6730c030c] AQUATERM_PATH moet misschien op /Applications/AquaTerm.app staan. Maar dat is van later zorg als de tweede test al werkte…

Beide tests werken! Dus zou eigenlijk op één of andere manier "set term aqua" permanent moeten kunnen zetten? (want krijg alleen resultaat als ik eerst deze regel heb getypt, anders doet hij na heropstarten dus gewoon niets...)

Pib

Ik weet niet precies hoe het moet (misschien iemand anders op 't forum, in het bijzonder het command line forum denk ik), maar je kunt de [i:74ae0c16ec]environment variable[/i:74ae0c16ec] (omgevingsvariabele) [code:1:74ae0c16ec]GNUTERM[/code:1:74ae0c16ec] op [code:1:74ae0c16ec]aqua[/code:1:74ae0c16ec] zetten. Dan plot gnuplot automatisch naar AquaTerm.

Ik ondervind ook problemen met gnuplot. Ik had een recente versie van Aquaterm (1.0.), en probeerde vandaag gnuplot via de fink commander te installeren (3.8j.0); blijkbaar installeert deze standaard Aquaterm versie 0.3. Als ik nu iets probeer te plotten via gnuplot, krijg ik

[code:1:dd046ddb82]Display server (AquaTerm) is too old, please update it.
See http://qauaterm.sf.net for more info and download.[/code:1:dd046ddb82]

Een nieuwere versie van Aquaterm installeren lijkt niks uit te halen. Iemand een idee hoe dit probleem uit de weg te ruimen?

Thx, Sam