hover onder een cell met css.

weet iemand hoe ik het voor elkaar krijg als ik een knop in een cell in een tabel heb staan dat als ik over die knop hover.. dat dan ook de background van die cell veranderd..,... ik loop al de hele middag te pielen, maar ik kom er niet uit!

HTML: [code:1:c888148eb0]<td class="tada"><a href="#"></a></td>[/code:1:c888148eb0]

Stel dat je plaatje 200px breed is en 100px hoog.

CSS:

[code:1:c888148eb0]
.tada a {
display : block;
width : 200px;
height : 100px;
border : 0;
}

.tada a:hover {
background : url(mijnplaatje.gif) no-repeat 0 0 ;
}[/code:1:c888148eb0]

[code:1:6501d79ca1]display: block[/code:1:6501d79ca1] :D

Hmmm... Tennapel was me net iets uitgebreider voor :wink:

het gaat om [url=http://test.hs-l.com/]deze website..[/url] ik ga het straks proberen of het werkt.. dank je wel voor de tips..

ik moet alleen mijn css weer overhoop gaan gooien… maar dat maakt niet uit…
:D:D
dan zit ik tenminste niet de hele tijd op het terras…;)!

Style Master is een geweldige CSS-editor, waarmee je op een eenvoudige wijze die hoovers kan maken. [url]http://www.westciv.com/style_master/index.html[/url] Er zijn er natuurlijk ook andere.

ok ik ben er mee aan het pielen maar het lukt me niet.. kunnen jullie zien wat er mis is? de testsite staat nog steeds op http://test.hs-l.com

[code:1:3da6231d18].ik {
background-color: #E7EF00;
width: 104px;
height: 104px;
font: 11px/20px Arial, Helvetica, sans-serif;
text-align: left;
}
.ik a {
display : block;
background-color: #E7EF00;
width : 104px;
height : 104px;
font: 11px/20px Arial, Helvetica, sans-serif;
text-align: left;
;
text-decoration: none;
}
.ik a:hover {
background : url(images/har1.jpg) no-repeat 0 0 ;
text-decoration: none;
}[/code:1:3da6231d18]

http://www.xs4all.nl/~mosm/Blogtest/test.html

Daar staat een werkend voorbeeld. Even een ‘view source’ doen.

[quote:44b8da1417="tennapel"]http://www.xs4all.nl/~mosm/Blogtest/test.html

Daar staat een werkend voorbeeld. Even een ‘view source’ doen.[/quote:44b8da1417]

super relaxed dat je me zo helpt, maar ik snap niet waarom het bij mij nu niet werkt heb het precies hetzelfde ingevuld… (ff opnieuw uploaden)

heb hem nu upgeload... maar kan jij in mijn source zien wat er verkeerd staat?

Ik zie dit in de sourse staan:

[code:1:cc53d491ea].ik a:hover {
 background : url(http://test.hs-l.com/images/har1.jpg) no-repeat 0 0 ;
tex[/code:1:cc53d491ea]

Die rare A duidt erop dat met het kopieren uit de browser spaties e.d. als ‘rare tekens’ vertaald worden die niet begrepen worden vervokgens. Even handmatig je code opschonen in BBEdit of texteditor o.i.d. en dan opnieuw uploaden.

ehm,.. ok hij doet het......

maar… niet helemaal… het plaatje opent niet helemaal…
ik duik er weer in… :smiley:

[quote:d4caec08a7="HS-L"]ehm,.. ok hij doet het......

maar… niet helemaal… het plaatje opent niet helemaal…
ik duik er weer in… :D[/quote:d4caec08a7]
heeey hij doet het… alleen het plaatje opent een pixel te laag in de cel…
nog ideeen?

Ik zie dat de cellen uit elkaar gedrukt worden (witte lijntjes), dus 1 van de HTML elementen is te groot en duwt de cellen naar buiten toe. Ik zou daar even naar gaan speuren.

[beetje offtopic] kontakt met twee k's is dat wel juist geschreven? Ik ben geen taalgod hoor, maar meestal zie je het toch met 2 c's? [/beetje offtopic]