installeren php en mysql

Misschien overbodig, maar toch altijd handig:

Kijk eens op www.serverlogistics.com. Op deze site kun je gratis installer packacjes downloaden voor apache2, php, mysql, tomcat, etc. Allemaal kant en klaar voor OSX, inclusief handleiding en preference panes. Hierdoor is het mogelijk om via je system prefs de apache en mysql servers te bedienen.

[quote:6a9e10fd18="®"]Misschien overbodig, [/quote:6a9e10fd18]

Nogal ja, ik heb het er in de posts hierboven al uitgebreid over gehad… :?

[quote:62964dfa36="Reinier"]

Nogal ja, ik heb het er in de posts hierboven al uitgebreid over gehad… :?[/quote:62964dfa36]

Ik doelde met overbodig eigenlijk op het feit dat het probleem van de topicstarter waarschijnlijk al opgelost was, maar wilde voor de volledigheid verwijzen naar serverlogistics. Toen ik daar gisteren naar zocht (zowel site search als forum search), kon ik hierover niets terugvinden. Het zal wel aan mij liggen, maar gisteren om 3.21pm toen ik dit bericht plaatste, heb ik ook in dit topic geen directe tekstuele verwijzing gezien. Ik helaas niet alle links tot aan de href-tag toe gecontroleerd. Nu staat er toch een tekstuele verwijzing en geeft de search ook resultaat, vreemd…

Het spijt mij in ieder geval voor de extra overbodigheid.

[quote:f11089ef15="sanne"] - type "sudo open -a TextEdit /etc/httpd/httpd.conf" TextEdit will open with the web server configuration file - onderaan het bestand heb ik in TextEdit toegevoegd: AddType application/x-httpd-php .php AddType application/x-httpd-php-source .phps - het document bewaren leek niet te lukken ook al koos ik voor Overwrite, maar later bleken de regels toch wel in het bestand te staan ?? [/quote:f11089ef15]

Ik heb ff de zoekfunctie gebruikt en toen kwam ik op dit (oude) onderwerp uit.
Ik ben nu met hetzelfde bezig. Apache2 is goed geinstalleerd, PHP werkt alleen nog niet. Het enige wat ik volgens mij nog moet doen is die regels in dat bestand krijgen. Maar het opslaan lukt niet en later staan ze er ook niet zomaar in oid? Weet iemand een manier om die regels er toch in te krijgen? En ik neem aan dat ik ze gewoon onderaan kan zetten zonder # ervoor, wat voor (bijna) alle andere regels wel staat.

Ik heb die regels er intussen wel bij gekregen, maar het werkt nog niet. Ik heb het bestand info.php , met de volgende code

[code:1:b51de9b09d]<html>

&lt;head&gt;
	&lt;title&gt;&lt;/title&gt;
&lt;/head&gt;
&lt;body&gt;

<?php
phpinfo();
?>

&lt;/body&gt;

</html>[/code:1:b51de9b09d]

in Library/Apache2/htdocs geplaatst, daar hoort het toch?
Ik zie gewoon een blanko pagina. :?
IEmand die iets weet?

in je httpd.conf vind je al de regels: [code:1:6e12d0dfbf] #LoadModule php4_module libexec/httpd/libphp4.so [/code:1:6e12d0dfbf] en [code:1:6e12d0dfbf] #AddModule mod_php4.c [/code:1:6e12d0dfbf] hiervoor hoef je alleen het hekje weg te halen;

onderaan staat al:

[code:1:6e12d0dfbf]
<IfModule mod_php4.c>
# If php is turned on, we repsect .php and .phps files.
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

# Since most users will want index.php to work we
# also automatically enable index.php
&lt;IfModule mod_dir.c&gt;
    DirectoryIndex index.html index.php
&lt;/IfModule&gt;

</IfModule>
[/code:1:6e12d0dfbf]
dus je dit hoef je niet meer toe te voegen

Die codes staan er bij mij nog niet in! Onderaan stond bij mij: [code:1:9240a4cd07]#<VirtualHost *> # ServerAdmin webmaster@dummy-host.example.com # DocumentRoot /www/docs/dummy-host.example.com # ServerName dummy-host.example.com # ErrorLog logs/dummy-host.example.com-error_log # CustomLog logs/dummy-host.example.com-access_log common #</VirtualHost>[/code:1:9240a4cd07] Ik zal even de laatste code kopieren er inn zetten en veranderen, kijken alsof het werkt. Vast bedankt in ieder geval. Misschien dat iemand de hele complete goedwerkende code even kan posten, zodat ik die gewoon over kan nemen? Zou handig zijn denk ik!

Ik denk laat ik het nog eens proberen. Ik start Apache op, en het werkt! Bedankt voor het meedenken walinsky!