Krijg Java 1.4.2 niet geïnstalleerd (Opgelost)

Hallo,

heb het nu reeds enkele keren geprobeerd, maar de Java update installeren lukt met niet.
Ik heb reeds van alles geprobeerd om mijn Appletje te controleren (permissies hersteld, fsck in single user mode, Norton :? eroverheen, enkele weken gewacht tot mijn leverancier Diskwarrior binnenhad en deze nu ook erover), geen problemen meer te rapporteren over mijn systeem.

Nu geef ik software-update (nogmaals) de opdracht “installeer 1 onderdeel”, daarna vraagt ie mijn wachtwoord, dan sluit het venster en krijg ik een dialoogvenster “Het programma Software Update is onverwacht gestopt”

Ik weet uit een vorig draadje dat ik niet de enige ben, maar dat onderwerp ging toen meer over Safari-update en diegenen die dit probleem stelden werden toen ook niet geantwoord. Vandaar mijn nieuwe post in de hoop dat hier wel een antwoord uitkomt?

De java update is ook te vinden op de site van apple, http://www.apple.com/benl/downloads/macosx/

Alle updates zijn er trouwens te vinden, niet zo handig als one click, maar het werkt wel.

Een tijdje geleden bleef software update bij mij ook hangen,
enkele dagen later werkte het weer probleemloos.

Anyway, succes ermee.

Netjes gedowloaded, package dubbelklikken, krijg dialoogvenster:

“U kunt deze software niet op dit volume installeren. Mac OS X 10.2.6 or later is required for this update”

Vreemd, ik draai nochtans Panther (10.3.2)?

verkeerde gedownload?

"U kunt deze software niet op dit volume installeren. Mac OS X 10.2.6 or later is required for this update" Dat zal ook de reden zijn dat Software-update crasht.

Wanneer je ’ over deze mac ’ aanklikt, onder :apple:,
staat er dan ook 10.3.2 ?

Heb je alle vorige updates wel kunnen installeren?

:?

Beiden bedankt voor de reactie, maarreu...

Java 1.4.2, dus de juiste gedownload.

“Over deze Mac” (blauw appeltje) > Mac OS X, Versie 10.3.2

En ik heb idd. alle andere updates kunnen installeren (waaronder 10.3.2!)

Please andere ideeën?

Je hebt toch echt de verkeerde. Bij Java 1.4.2 staat 10.3.1 of later vereist. Voor Java 1.4.1 geldt namelijk inderdaad 10.2.6 of later. Kan ook een fout van Apple zijn, hoor, soms kloppen de links niet. Java 1.4.2 is 28 MB groot, Java 1.4.1 is 40 MB, misschien kun je zo zien welke je hebt.

Hier staat de juiste: http://docs.info.apple.com/article.html?artnum=120309

[quote:fc69b5d987="Gijs"]Je hebt toch echt de verkeerde. Bij Java 1.4.2 staat 10.3.1 of later vereist. Voor Java 1.4.1 geldt namelijk inderdaad 10.2.6 of later. Kan ook een fout van Apple zijn, hoor, soms kloppen de links niet. Java 1.4.2 is 28 MB groot, Java 1.4.1 is 40 MB, misschien kun je zo zien welke je hebt.

Hier staat de juiste: http://docs.info.apple.com/article.html?artnum=120309[/quote:fc69b5d987]

Nope, het is net deze die ik niet kan installeren. Momenteel heb ik de 1.4.1.

Installer zegt dat ie deze zal vervangen door 1.4.2, Als ik doorga en de software-licentie overeenkomst accepteer gaat het door naar “Doelvolume selecteren”. Daar krijg ik op mijn schijf een knalrood icoon met wit uitroepteken en daarbij de reeds vermelde dialoog: U kunt de software niet op dit volume installeren. Mac OS X 10.2.6 or later is required for this update."

Ik begin net niet te wanhopen :oops:

Nu is het helemaal compleet!

Ik dacht: weg met het Nederlandstalige systeem en over naar het Engelse. (De tweetaligheid in de dialoogvensters die ik kreeg deden me twijfelen)

Dus in de Engels versie dan nogmaals geprobeerd, met als gevolg een dialoogvenster: " You cannot install this software on this volume. Please install de Java 1.4.1 Update before proceeding with this update"
Hier kreeg ik dus een heel ander verhaal, geen geleuter meer over systeem maar nu over Java, ik kom dichterbij denk ik maar… waarom staat Java 1.4.1 Plugin settings reeds in mijn Utilities? OK, proberen maar:

Dan toch maar 1.4.1 gedownload. Installeer, en: “You cannot install this software on this volume. This volume does not contain a version of Java that needs updating”

Help!

[url=http://forum.macosx.nl/viewtopic.php?p=179201#179201]Mijn oplossing.[/url]

Ik kreeg deze updater ook niet aan de praat (mededeling dat minimaal 10.2.8 moest zijn geïnstalleerd, G4 AGP 350mhz OS 10.3.3). Op alle andere machines werkte deze update probleemloos (zowel via Software Update als aparte download en installeren. Van alles al geprobeerd, (Permissies e.d.) maar de volgende oplossing werkte: Gevonden in Apple - Discussions [url]http://discussions.info.apple.com/WebX?14@4.3wSsa0IOjCd.0@.68907c63/2[/url]

[quote:b438c2ce92]There is a way to remove the installation checks for the installer but, since it is not supported, I am afraid that you will have to use it at your own risks. Would you want to try it, here are the steps :

  1. Copy the installer to your desktop
  2. Control-click on the installer package and select “Show package contents”
  3. Open the “Contents” and “Resources” folders
  4. Locate the “VolumeCheck” file and click on it once
  5. Enter Apple-I. In the window that appears, select “Permissions” and make sure that both the owner and the group are set to your username.
  6. Close the get info window and drag the script to the trash.
  7. Launch the installer

This should force the installer to work. However, note that I have been able to run it without any issues on a configuration similar to yours, by downloading it from the Apple site – I just tried again.

Again, this is not a supported procedure…

Let me know if this helps !
F.J. (François Joseph de Kermadec) [/quote:b438c2ce92]

Ik heb stap 5 niet gedaan en meteen het VolumeCheck file in de trash gegooid.
De installer werkte vlot en zonder problemen.

PS
Dit kon wel eens de oplossing voor andere weigerachtige installers zijn, VolumeCheck werkt niet altijd zoals het hoort.
Maar zoals François Joseph http://www.oreillynet.com/pub/au/1339 en http://www.fjzone.org terecht opmerkt: Do this at your own Risk.
Je hackt immers de installer.
Systeemupdate naar 10.3.3 heb ik probleemloos op een aantal Macs vanaf CD toegepast, maar op de Imac 17" G4 flat-panel van mijn dochter kreeg ik ook de domme mededeling dat er geen 10.3 geïnstalleerd was. Bovengenoemde hack niet toegepast, eerst via Software Update geprobeerd en die werkte wel (ra ra hoe kan dat?) anders had ik dit geprobeerd.

Bedankt! Zo is het mij ook gelukt de updater te installeren. Heb ook de stap overgeslagen die jij had overgeslagen en voila - hij deed het.

Janny

bedankt manne. had het trucje met die volumecheck ook nodig hier!