Lijst met unieke waarden dynamisch uit een kolombereik in Numbers genereren

In kolom A heb ik waarden die daar vaker in voor kunnen komen. B.v.:

Amsterdam

Ede

Renkum

Ede

Arnhem

Ede

Oosterbeek

Utrecht

In kolom B wil ik de zelfde lijst hebben staan, maar dan alleen met unieke waarden, dus Ede maar 1 maal.

Op de Excel manier zou het er ongeveer zo uit moeten zien: {=ALS.FOUT(INDEX(A$2:A$15;VERGELIJKEN(ONWAAR;ISGETAL(VERGELIJKEN(A$2:A$15;$B$1:B1;0));0));"")} dat is een matrix-formule.

Concreet, wat moet ik doen om mijn lijst in kolom B te krijgen?

Alvast heel hartelijk dank!

Laat me raden waar je woont :wink:

Die plaats staat er maar 1x in!

zoiets als dit

 

{=INDEX(lijst,MATCH(0,COUNTIF(unieklist,lijst),0))}

 

lijst is je eh lijst met alle namen b.v A1:A10

unieke lijst is de eerste regel waar je nieuwe lijst begint. b.v $B$1:B1

Sleep die regel naar beneden zodat de formule doorrekent b.v resultaat in B10 is dan $B$1:B10

 

Als aanvulling. De code zet je dus in B1 en vandaar sleep je de code regel naar B10. De code wordt bwv verder gekopieerd. Enige wat veranderd is B1 in de code. En gebruik control + shift + enter na het ingeven van de regel.

Beste mensen,

 

Dank voor het meedenken!

Toch lukt het nog niet… Heb een plaatje bijgevoegd ter verduidelijking.

Wat probeer je te bereiken?

in je code moet B7 bij jou B1 zijn. trek de cel naar beneden tot b.v B10

die B1 is relatief en zal dan aangepast worden aan zijn positie als het naar beneden trekt.

 

Ik wil in kolom B (dynamisch) onder elkaar hebben staan: Maandag Dinsdag Donderdag Zaterdag.

In B1 staat: {=INDEX(A1:A7;VERGELIJKEN(0;SOM.ALS($B$1:B1;A1:A7);0))} maar dan geeft hij nog een syntaxisfout…

Overigens, als ik hem zo intyp, dan kan ik de formule niet plaatsen met trol en shift en enter…

Zal eens een site opzoeken voor je. Dit was uit losse handje.