Link --> Tekst

Ik heb een beetje vreemd probleem, ik ben bezig een hele hoop data te kopieren (naar Excel) uit een html file, maar nu is een groot deel van de data een link verwerkt. Is er een optie om deze linkweergave op een of andere manier uit te schakelen, zodat deze gewoon als tekst kan worden gekopieerdt? Iemand een sugestie, (ben op de hoogte van de Hyperlink optie in Excel, maar dat kost me nog teveel tijd)

Wat me het eerste te binnen schiet is dat je in excel 'alles' zou kunnen kopieren naar een nieuw werkblad en dan met paste special alleen de waarden. Ik vermoed dat je dan van je links af bent. Misschien dat paste special... nog meer leuke opties heeft waar je wat aan hebt.

Ik had dat eergisteren ook. Superirritant. Heel office mag van mij dingen die op url's lijken negeren, ipv hyperactief en blauw te maken. Maar in beide preferences niks hiervoor gevonden (excel en word). Ik had een adressenlijst en steeds wanneer je een veld aanklikt wordt Mail gestart. Onozel!

[quote:723bae1fe9="fistkikker"]Wat me het eerste te binnen schiet is dat je in excel 'alles' zou kunnen kopieren naar een nieuw werkblad en dan met paste special alleen de waarden. Ik vermoed dat je dan van je links af bent. Misschien dat paste special... nog meer leuke opties heeft waar je wat aan hebt.[/quote:723bae1fe9]

Idd een goede suggestie, maar het probleem is dat het om een 20 mb file gaat en dat zijn een hele boel links! Ik wil dus eigenlijk een optie die html gewoon in tekst omzet, want in Excel zitten alleen maar optie die het net niet zijn.

Zit er verder belangrijke opmaak in? Anders kun je de boel opslaan in een kaler bestandstype en dan opnieuw openen. Desnoods een komma-gescheiden tekst-bestand.

Dan blijf je die nare links houden.

[quote:add132afd6="OEPS"][quote:add132afd6="fistkikker"]Wat me het eerste te binnen schiet is dat je in excel 'alles' zou kunnen kopieren naar een nieuw werkblad en dan met paste special alleen de waarden. Ik vermoed dat je dan van je links af bent. Misschien dat paste special... nog meer leuke opties heeft waar je wat aan hebt.[/quote:add132afd6]

Idd een goede suggestie, maar het probleem is dat het om een 20 mb file gaat en dat zijn een hele boel links! Ik wil dus eigenlijk een optie die html gewoon in tekst omzet, want in Excel zitten alleen maar optie die het net niet zijn.[/quote:add132afd6]
Voor ieder werkblad doe je [command] A [command] C, opent een nieuw werkblad en doet paste special… alleen de waarden. Je links zijn dan gewoon de tekst die er stond. Nog geen 10 seconden werk. En dan exporteert je.
Dus alleen onwerkbaar als je heeeeeel erg veel werkbladen in het bestand hebt staan. Andere oplossingen zijn er niet.

@martiniman; in excel kon ik de optie niet vinden, maar in Word kan je het automatisch maken van links uitzetten in de autocorrect… opties: Tools → Autocorrect… → autoformat as you type → vinkje weg bij replace as you type …internet paths with hyperlinks.

Ik vond dit applescript dat webpagina's naar .txt file omzet dat mij uit de brand heeft geholpen.

[code:1:c92333c1fe]set myData to ""

tell application "Safari"
activate
set myURL to URL of document 1
set myData to do JavaScript "getSelection();" in document 1
if myData is "" then
set myData to text of document 1 as text
end if
end tell

set myDate to current date
set fPath to path to desktop
set fName to (do shell script "date "+%Y-%m-%d"") & ".txt"
set myFile to open for access file ((fPath as string) & fName) with write permission
write "=== " & return & "Date: " & myDate & return & "Text from: " & myURL & return & return & myData & return & return to myFile starting at eof
close access myFile
beep[/code:1:c92333c1fe]

[quote:4939ba3c6c="Martiniman"]Ik had dat eergisteren ook. Superirritant. Heel office mag van mij dingen die op url's lijken negeren, ipv hyperactief en blauw te maken. Maar in beide preferences niks hiervoor gevonden (excel en word). Ik had een adressenlijst en steeds wanneer je een veld aanklikt wordt Mail gestart. Onozel![/quote:4939ba3c6c]

Dat staat op een andere plaats:

  • Kies menu Format;
  • Kies item AutoFormat…;
  • Klik op de knop Options;
  • Verwijder de vink bij “Internet paths with hyperlinks”;
  • Vink dot ook af op het tabblad “AutoFormat As You Type”.
    Als het goed is ben je er nu, bij het maken van nieuwe tekst, vanaf.

Per hyperlink kan je trouwens verwijderen:

  • Rechtsklik op de hyperlink;
  • Kies submenu Hyperlink, item Edit Hyperlink…;
  • Klik op de knop “Remove Link”.

Succes!

Welk vinkje precies, of hebben we verschillende Office versie's (2004) [img:653dc22782]http://forum.macosx.nl/album_pic.php?pic_id=11774[/img:653dc22782]