Mac doet niet updaten

Hallo iedereen,
Mijn Mac (powermac g5 late 2005) doet niet updaten naar 1.5.8 (van 1.5.1) wat erg nodig is. Ik heb de nieuwere versie van iTunes nodig om m’n iPhone te kunnen synchroniseren want ik heb nu iTunes 7 en daar heb je 10 voor nodig. Ook wil ik de nieuwere versie van iLife installeren ('09) en daar heb je ook die update voor nodig. Bovendien wordt de computer weer een stuk beter na de update, de Mac zegt nu nog af en toe : you need to restart your computer.
Help!