Netwerkkabel of poort probleem

Afgelopen week klapte opeens mijn verbinding met het internet via de netwerkkkabel.
Vreemd want de kabel lijkt in orde te zijn als ik er andere randapparatuur aan hang.
Ik gebruik een timecapsule waar ook een wifi netwerk aan hangt. Op die timecapsule heb ik een netwerkkabel die naar mijn Mac gaat. Dat werkt dus niet, maar als ik de wifi aanzet heb ik geen probleem (op een minder snelle verbinding na dan) . Als ik aan de netwerkkabel die ik dus normaal in mijn Mac plug een oud routertje plaats en deze met een kabel weer doorverbindt naar mijn Mac is er ook geen probleem met bedraad internet. Ik begrijp er niets van. Wellicht is er iemand die dit probleem zo door heeft.
Voor de volledigheid: ik heb vorige week een upgrade gedaan naar Mountain Lion (in het begin geen enkel probleem gehad)

Probeer dan gewoon een andere ethernetkabel die je in je Mac doet. Werkt dat ook niet, kan het zijn dat de ethernetpoort op je Mac kapot is.

In feite heeft-ie dat al gedaan door een TC > twijfelkabel > router > kabel > iMac verbinding te maken.
Als de twijfelkabel hierin wel werkt zou je zeggen dat alle onderdelen in orde zijn.

Ik zou de volgende zaken checken:
* kabel (toch een keer in z'n geheel vervangen door een andere)
* kijken of er niet ergens een softwarematige fout zit (ip adressering/dhcp server, netwerksnelheden, etc.).

Maar 't is inderdaad vreemd.

Twijfelkabels kunnen het elders prima doen doordat je ze dan net op dat moment in de goede houding hebt liggen. Het is veel beter om gewoon een paar andere kabels te gebruiken en even iets verder te testen dan maar 1 ding. Iets wat met name bij twijfelkabels van groot belang is omdat die juist de ene keer prima werken en de andere keer niet (het heten niet voor niets twijfelkabels ;)).