Nieuwe APFS problemen in mijn Mac Pro met Mojave

Veel mensen gebruiken Carbon Copy Cloner. Ik gebruik het al jaren probleemloos. Nu had ik een probleem en dat is met die snapshots van APFS. Het probleem van niet vrijgekomen schijfruimte deed zich voor vooraleer ik Daisy Disk gebruikte, dus is dat programma niet de schuldige. Op MacRumors zijn er verschillende threads over het probleem dat er niet genoeg schijfruimte vrijkomt bij legen van de prullenmand met APFS. Trouwens CCC was verantwoordelijk voor 50 GB, er is nu veel meer vrijgekomen (meer dan 120 GB extra). En daarom ben ik ervan overtuigd dat die APFS van Mojave de oorzaak is. Want zoiets heb ik bij HFS+ nooit meegemaakt. Sorry, dat is mijn mening. Ik gebruik trouwens met Mojave veel minder 3rd party tools dan vroeger.

Wat er ook van weze, de vriendelijke mensen van Daisy Disk Support hebben het probleem voor mij opgelost. Ik ben hen dan ook dankbaar.

De Apple Support Community staat vol met apfs problemen. Problemen die wij ook hadden, en waardoor we terug zijn gegaan naar hfs+. Vooral het trage opstarten, trage schijfcontroles, valse meldingen over een volle schijf en (het ergste) de freezes na wake from sleep waren een kwelling. Met hfs+ zijn al die problemen weer verdwenen.

Sedert de aanvullende update 10.14.6 geen vastlopers meer met APFS bij het ontwaken uit de slaapstand met mijn Mac Pro 5,1. Systeem is duidelijk stabieler dan vroeger. Heb wel enkele weken geleden de schijf nog eens hergeformatteerd en alles met Carbon Copy Cloner teruggezet. Geen schijffouten meer. Een clean install was niet nodig. Gelukkig maar, want dan had ik wellicht moeite om mijn Adobe Creative Suite C6 nog aan de praat te krijgen.
Enige probleem blijft de safe boot via mijn SSD geïnstalleerd op de OWC Accelsior PCI-kaart. Dat duurt nog meer dan vier minuten.
Dan krijg ik een melding van disk utility dat een fout het opstarten vertraagt. Ik ben ten rade gegaan bij anderen op MacRumors die ook een OWC Accelsior hebben en ze ervaren hetzelfde. Blijkbaar is deze bug niet opgelost. Maar gelukkig is er geen foutmelding bij normaal opstarten. Dus ik kan daarmee leven.
Einde goed, al goed. ?

Dat kan er wellicht aan liggen dat in Safe Mode bepaalde (benodigde) drivers niet geladen worden.

Precies.

Dit is juist een functie van Safe Boot: alleen het laden van de ‘vereiste kernelextensies’, zodat je bij problemen van corrupte drivers je toch kunt opstarten en het probleem kunt tackelen. Staat ook genoemd in de beschrijving van Apple: De veilige modus gebruiken om problemen met de Mac op te sporen

Dus geen bug maar correct systeem gedrag.

In safe boot mode heeft mijn MacPro 5,1 vier minuten nodig, mijn MacBook Pro 2015 slechts dertig seconden. Ik heb voor die OWC PCI-kaart geen driver moeten installeren, maar misschien zit er één ingebouwd in het MacOS. Dat zou inderdaad een verklaring kunnen zijn.

Maar zou dit dan geen bug zijn van disk utility?

The disk needs to be repaired.
Problems were found with the partition map which might prevent booting.

Deze melding verschijnt bij mijn Mac Pro 5,1 in de veilige modus. Als ik dan gewoon opstart is die melding verdwenen en wordt gerapporteerd dat de schijf OK is. Andere gebruikers van die OWC Accelsior kaart bevestigen dit.

Het voornaamste is dat alles nu werkt naar behoren.

Ook dat kan je wijten aan het ontbreken van de juiste drivers. Kennelijk gebruikt de OWC drive een andere (niet standaard) driverset binnen macOS dan de MacBook Pro, die standaard wel door Apple ondersteund. Dat kan zowel het snelheidsverschil als de foutmelding verklaren omdat dan teruggevallen moet worden op een standaard driver die wellicht niet 100% aansluit bij de OWC drive. Aangezien de drive prima functioneert bij normaal opstarten, zou ik me daar zeker niet druk over maken.

Om een voorbeeld te geven: in bepaalde gevallen wordt de eigen AirPort driver niet geladen in SB, en heb je dus geen WiFi. Daaruit kun je wel extrapoleren dat het niet raar is dat jouw set-up in SB dit gedrag vertoont.

Bedankt voor de verhelderende uitleg Night en GoeieDag.

Ik heb op mijn tweede Mac Pro 5,1 die eveneens een OWC Accelsior PCI-kaart heeft met een SSD die HFS+ geformatteerd is (Yosemite) ook eens een safe boot gedaan. Hij start op in 50 seconden (vs 4 minuten). Zou het niet kunnen dat de veel langere wachttijd bij Mojave zijn oorzaak heeft in APFS?

Ja. Met dezelfde oorzaak (driver) als grondslag.