Php flash en mailform

Goede middag,

Ik probeer een mailform aan de gang te krijgen, maar er klopt blijkbaar toch nog iets niet.

Het php script ziet er zo uit:

[code:1:fd014e7a55]
<html>
<head>
<title>Contact Formulier</title>
<body>
<?php

$TextVariable = ‘&resultaat=’;
$response = ‘De data is verzonden.’;

echo $TextVariable;
echo $response;

mail ("chonazz@mac.com", "Bericht", "

Bericht

Naam:
$naam

Email-adres:
$email

Bericht:
$bericht

");

?>

</body>
</html>
[/code:1:fd014e7a55]

En op de verzend button staat:

[code:1:fd014e7a55]
on (release) {
resultaat = "Verzenden van data";
loadVariablesNum ("mailform.php", 0, "POST");
}
[/code:1:fd014e7a55]

De variabelen kloppen, en als ik op verzenden klik dan komt er wel te staan dat ie bezig is, maar hij krijgt geen response?

Moet ik in httpd.conf ofzo nog iets invullen om dit mailform te laten werken?
Moet er eerst iets in php worden ingesteld ofzo?
Heb er eigenlijk niet zoveel ervaring mee, maar ik wil het wel graag werkende hebben :slight_smile:

Groeten
Jonas

Als je variabelen naar flash file sturen dan doe je dit zo:

&response = De data is verzonden.

echo ‘&response=’ . $response;

Waar komt er te staan of het verzonden is? Waar check je je returns? waarom staat er html in die php file, die moet er dus als eerste uit, flash verwacht sowizo iets in de vorm van [code:1:551a08a090] data=bladiebla [/code:1:551a08a090] in jouw geval komt er nog allerhande html meuk mee ..

kijk eens in de help en zoek eens op LoadVars …

[quote:4191d97565="zimmen"]Waar komt er te staan of het verzonden is? Waar check je je returns? waarom staat er html in die php file, die moet er dus als eerste uit, flash verwacht sowizo iets in de vorm van [code:1:4191d97565] data=bladiebla [/code:1:4191d97565] in jouw geval komt er nog allerhande html meuk mee ..

kijk eens in de help en zoek eens op LoadVars …[/quote:4191d97565]

Hoe bedoel je [code:1:4191d97565]data=[/code:1:4191d97565]
Moet dit voor het php script komen?
Moet ik dan nog iets in flash veranderen? Of klopt het daar wel?

De html heb ik helemaal weggehaald:

Dus nu zou ik zo iets moeten hebben:

[code:1:4191d97565]data=
<?php

$TextVariable = ‘&resultaat=’;
$response = ‘De data is verzonden.’;
echo ‘$response=’ $response;

echo $TextVariable;
echo $response;

mail ("chonazz@mac.com", "Bericht", "

Bericht

Naam:
$naam

Email-adres:
$email

Bericht:
$bericht

");

?>
[/code:1:4191d97565]

Of klopt dit nog steeds niet?

http://www.sephiroth.it/tutorials/flashPHP/email/

[quote:bcef682e2f="konijn"]http://www.sephiroth.it/tutorials/flashPHP/email/[/quote:bcef682e2f]

Thnx,

Nu weet ik tenminste al waar het probleem zich bevind!

Ik heb een php file aangemaakt met volgende code:

[code:1:bcef682e2f] <?
mail("chonazz@mac.com","test","Ok, it works");
?> [/code:1:bcef682e2f]

En deze in m’n map webpagina’s gezet, als ik dan het bestand oproep via de Browser zou ik een mailtje aan moeten krijgen…
Maar dit werkt niet?

Moeten er bepaade poorten open staan? Moet ik nog ergens iets ingeven zodat het wel werkt?

Groeten
Jonas

Ok , Ik had de php.ini nog niet ingesteld blijkbaar, heel dom van me... Nu doet

[code:1:e4d07cafd7]<?
mail("chonazz@mac.com","test","Ok, it works");
?>[/code:1:e4d07cafd7]

Het wel, maar

[code:1:e4d07cafd7]<?php
mail ("Chonazz@mac.com", "Bericht", "

Bericht

Naam:
$_POST[naam]

Email-adres:
$_POST[mail]

Bericht:
$_POST[bericht]

");
?>[/code:1:e4d07cafd7]

Doet het niet?
Variabele kloppen, en op de button heb ik

[code:1:e4d07cafd7]on (release) {
loadVariablesNum("mail.php", "0", "POST");
}[/code:1:e4d07cafd7]

Staan?
Ik blijf hier maar mee knoeien, en snap echt niet wat ik mis doe? [/u]