PPTP ADSL with MACOSX 10.2 jaguar: no pptp-gui

I realized that many articles are still referring to pptp-gui to connect to ADSL services. Also some of thoses articles state that it is impossible to use the VPN function of 10.2 to do so.

Lets correct this.

MacOSX 10.2 has integrated VPN (PPTP) support which makes it possible to connect to ADSL services (and other VPN related services) without using any 3rd party applications. Not only is this good news but it also deals with the shortcoming of pptp-gui which by any means was a great workaround for non-unix-adepts.

How to do ?

Below will be applicable for the KPN MxStream standard setup using an Alcatel Speedtouch Home modem. Since there are not too many specific setting this also can be adapted very easily to other ISPs

  1. Create a new location.
  2. In the Network preferences set your TCP/IP settings to
    IP: 10.0.0.150
    Netmask: 255.0.0.0
    Gateway: 10.0.0.138 (should also work without this)
  3. Choose the Network Port Configuration and delete the modem device. It will be displayed as disabled.
  4. Choose the Internet Connect application.
  5. You will be ask to use VPN. Choose it.
  6. Fill in login/password as stated with your ISPs account information.
  7. Fill in the router address ‘10.0.0.138 pc1’
  8. Click connect.
  9. Surf ahead!!!

Xa. The Internet Connect will keep the settings for later use.
Xb. If there is no traffic for the timeout period, Internet Connect will disconnect the line automatically.

We krijgen steeds meer berichten van anderstaligen, lijkt het wel.

Waar gaat dit precies over?

Was het teveel moeite om even een Nederlandse onderwerp-vermelding bij te voegen?

ben ik mee eens dit is een nl talige site dacht ik

als ik in een andere taal wil communiceren dan ga ik wel naar een ander talige site

dus gaarne in nl :finder:

De informatie die deze persoon hier plaats is daarentegen wel heel erg nuttig!

[quote:85e98e2a56]Thanks for posting this articles, I’ll translate it to dutch soon and place it in the “Tips & Tricks” section.[/quote:85e98e2a56]

Adriaan

Gelukkig geef jij wel een zinnig antwoord Adriaan.

Wat betreft het gezeur over de taal; De post lost zo’n beetje de helft van de OS X probleemvragen met adsl op, kunnen jullie dat misschien ook opmerken? Dit komt niet echt over als een hartelijk welkom.
:?:

[quote:58384470e4="stoef"]ben ik mee eens dit is een nl talige site dacht ik[/quote:58384470e4]

Gebruik zelf dan ook correct Nederlands.

sorry voor the engelse intrusie, maar want jullie nu ziet is mijn nederlands alleen goed om niet geschrieven te werden.

[quote:4afc0c8742="antron"] Xb. If there is no traffic for the timeout period, Internet Connect will disconnect the line automatically.[/quote:4afc0c8742]

Dit is toch geen voordeel? Lijkt me vervelend.
[i:4afc0c8742]This is no advantage, now is it? Seems annoying to me.[/i:4afc0c8742]

Sorry luitjes maar even in het engels . Antron I miss some information about the tcp/ip settings. Should i configure a ppoE or ppp using the modem? I tried your way but my identity was not accepted.

I hope you can help me/us more.
BTW my system broke up and i received an forced restart with three languages on the screen.
greetings Aljo

Ik hoop dat jullie het een beetje begrijpen en ja dit is een nederlandstalige site.Maar soms kan het handig zijn open te staan voor engelstalige vrienden die ons willen helpen.
Waarom zou Antron anders een nederlandstalige site bezoeken.

Alcatel-USB modem gebruikers, jullie weten toch dat je die blauwe kwal gewoon aan de gang kan krijgen in je X met het programmaatje van xs4all? Staat ergens op hun site. Is ong, 10 MB geloof ik, maar dan hb je ook verder nix meer nodig.

Co da's mooi maar dat gaat niet op voor de ethernetmodem van xs4all

Aljo

Aljo,

Let me start from the beginning since I am now in front of my computer. Please let me know on which point you are missing something. You might need to switch your menu language to english to find all points. With slight modification it also should be possible with XS4ALL ethermodems.

BTW, I am able to read dutch w/o problems - just the writing part is an insult to your language which I do not want to take part in for now.

  1. Open System Preferences - Network
  2. Open Location - New Location, name the new location
  3. Open Show - Network Port Configuration
  4. Mark Internal Modem & delete it (it will be disabled)
  5. Open Show - Built-in Ethernet
  6. Fill in:
    Configure: Manually - IP Address: ‘10.0.0.150’ - Subnet Mask: ‘255.255.255.0’ - Router: ‘10.0.0.138’ - DNS & Domains can be left empty
  7. Apply the setting, close System Preferences
  8. Start Internet Connect
  9. Continue, Use VPN
  10. Fill in the VPN Connection window:
    Server address: ‘10.0.0.138 pc1’
    User name & Password
    Mark Add to Keychain if you want to remember the settings

Antron

Antron,

Ik heb je duidelijke instructies gevolgd. Alles lijkt goed te gaan, hij maakt verbinding maar dan wordt ook bij mij - net als bij Jamba - de identiteit niet geaccepteerd.

Heb je nog een goed advies? Het zou mooi zijn als langs deze weg verbinding gemaakt kan worden.

Gerry

Same here: alle mogelijke instellingen geprobeerd, maar als het menens wordt komt altijd: identiteit wordt niet geaccepteerd. (mijn provider is XS 4all)

Toch maar eens de stoute schoenen aantrekken en het modem hacken…

Gerry, Bart, Niet vergeten dat je gebruikersnaam welke je hier moet invullen uit meer dan het eerste gedeelte van je email adres bestaat, maar zoiets moet zijn als: "bart@xs4all-basic-adsl" o.i.d.... :?

Eureka It Works.

This is the best tip which I have read since the introduction of OC X, because it is complete irritating that you have to fill in your password allways to make connection.

Thanks Antron,

Eureka het werkt.
Dit is de beste tip die ik heb gelezen sinds de introductie van OS X, want iedere keer je wachtwoord invullen als je verbinding maakt is toch wel heel irritant.

Bedankt Antron,

No it doesn.t work.

Two total crashes in a row.

What’s wrong over here.

Aljo

[quote:55f809dfc2="jamba"]No it doesn.t work.

Two total crashes in a row.

What’s wrong over here.

Aljo[/quote:55f809dfc2]
Bij mij lukt het ook niet. ben xs4all gebruiker.
na invoeren van het wachtwoord, bij mij bijv. 5 karakters, zie je dit veranderen in 7 karakters erna de mededeling dat je identiteit niet is geaccepteerd, ook met de toevoeging @xs4all-basic-adsl bij je gebruikersnaam
Help

OK. Ik zit bij Planet maar dat mag niets uitmaken.

Ga als volgt te werk…

1: Open Systeemvoorkeuren, Netwerk ga naar locatie: en maak een nieuwe locatie aan.
2: Ga naar Toon: Configuratie netwerkpoorten en verwijder alle vinkjes.
3: Vink de Ingebouwde Netwerkkaart aan en druk op de kop (pas nu toe)
4: Ga naar Toon: Ingebouwde Netwerkkaart en stel deze als volgt in.
5: Configureer: Handmatig
6: IP-adres: 10.0.0.150
7: Subnetmasker: 255.255.255.0
8: Router: 10.0.0.138
9: Laat DNS-servers en Zoekdomeinen leeg.
10: Open nu het programma Internetverbindingen, deze meld dat er verbinding gemaakt moet worden via VPN-PPTP klik op (OK)
11: Serveradres: 10.0.0.138 pc1
12: Gebruikersnaam: jouwacount@adsl-comfort (bv)
13: Wachtwoord: (om in teloggen bij je provider)
14: Zet een vinkje in: Voeg toe aan sleutelhanger.

Als de verbinding is gemaakt kunje het programma Internetverbindingen eventueel afsluiten.

Als alles volgens bovenstaand relaas is ingesteld zou het moeten werken, bij mij in ieder geval wel.

Bij mij (iMac/10.2.3/xs4all) gebeurt exact hetzelfde als bij Lukas. Na Ok worden twee extra tekens aan het wachtwoord toegevoegd en identiteit vervolgens niet geaccepteerd. Dit lijkt op een bug. Misschien dat verwijderen van prefs helpt?

Gerry