ProTools 'Diet'

Beste audio forumleden,

Aangezien ik veel ‘inprik’ en een verwoed editor ben trekt ProTools bepaalde nummers niet meer, omdat er een overschot aan handelingen in audiofiles wordt bewaard.
Heb (zoals aangegeven) de buffersize al vergroot, CPU usage limit verhoogd en de Playback buffer op 8 gezet. Wat wel helpt maar eén session in het bijzonder kan meestal niet meer in zijn geheel worden afgespeeld, of zelfs gebounched.

Nu vroeg ik me af of er een ProTools variant bestaat van iPhoto Diet, waarbij alle niet gebruikte opnames/bewerkingen verwijdert worden. Optimaliseren dus, wat ik ook ken van HD recorders, waarna je meteen gigantisch veel ruimte terugkrijgt.

Of zijn er andere mogelijkheden om een session ‘af te slanken’?

Ben benieuwd.

Groet,

André.

Je kan je tracks 'consolideren'

Eerst even je sessie copieren, de copie openen, een track selecteren en dan uit het edit(?) menu consolidate kiezen.

Dan worden alle edits , automatisering etc ‘uitgevoerd’ ahw, en houd je een zuiver audiospoor over.
Ik weet niet of het meerdere tracks tegelijk kan, en wat er dan gebeurd…

Zoals het nu lijkt kan dit wel, maar mag het helaas niet baten. Misschien moet ik de tracks een voor een consolideren, i.p.v. allemaal tegelijk.

De CPU usage limit (en de buffersizes) zou ik als je naast PT geen andere applicaties draait sowieso op het maximum zetten. Hierdoor krijg je wel meer latency/vertraging, maar daar heb je bij editting/mixage geen last van. (nouja niet helemaal correct, want de kanalen t.o.v. elkaar krijgen ook meer vertraging wanneer je plugins gebruikt, maar dat valt wanneer het geen stereo signaal, of multimic'ed drumkit is over het algemeen te verwaarlozen. Dus met andere woorden niet zo belangrijk in dit geval.)

Er zijn een aantal dingen die je kunt doen om je sessie “op te schonen”. Dit is allemaal prima uitgelegd in de manual, die ook te downloaden is trouwens. Hiervoor moet je in het Audio menu zijn. Hier zie je staan: Compact selected en Clear selected. Deze zijn niet aan te klikken wanneer je geen audio in de (audio-) regionslist geselecteerd hebt.

Soms heb je langere opnames gemaakt en daarna over de helft van de file weer een nieuwe file opgenomen. Van de eerste file staat enkel nog een region in de sessie, maar de gehele file kun je dus niet weggooien omdat er een gedeelte van in gebruik is. Selecteer de region en daarna compact selected. Dan krijg je een popup box waarin je kunt bepalen hoeveel overlengte aan de kop en de staart van de file je wilt behouden (dit wordt ook wel een “handle” genoemd in vakjargon). Dit is soms handig voor bepaalde edits en dan is het vervelend wanneer er geen geluid meer is aan het begin of eind van een file, dit is vooral belangrijk bij geluid voor filmeditting, maar ook muziek editting is dit vaak handig. Hierna wordt het gedeelte van de file wat niet in je sessie zit dus weggegooid en PT schrijft voor de region een nieuwe file. Hierover later meer.

Regions die niet gebruikt worden kun je in principe altijd weggooien (da’s enkel een aanduiding voor een gedeelte van een langere file), maar wanneer van een langere audiofile een ander gedeelte gebruikt word, dus een andere region, dan kun je die file niet zonder meer weggooien. Als je in Audio/Select kijkt krijg je een submenuutje waarin je ziet staan select “unused regions” en select “unused except for whole files”. Het is een goede zaak om die 2e optie regelmatig toe te passen, hierdoor wordt je sessie weer stukje sneller en handelbaarder. Als je hierna op “clear selected” klinkt dan krijg je een pop-up window waarin een aantal opties staan. Remove, delete, en cancel. De delete optie is grijs, niet aan te klikken, omdat regions geen fysieke files zijn. Wanneer je dit doet krijg je dus nog geen harddisk ruimte terug. Waarom niet gelijk op de “unused regions” klikken?. Omdat je dan popop windows krijgt bij langere files waarvan wel regions in gebruik zijn maar niet de lange file zelf en dan moet je heel goed oppassen dat je die niet weggooit anders zijn de overige regions daarvan ook leeg!

Wil je je sessie maximaal opschonen, dan moet je dus wel die optie kiezen. Dus, “unused regions”. En dan bij “clear selected”, klink je op “delete”. Hierna moet je goed op je tellen passen. Er zijn 2 berichten. Een zegt dat er regions van een file in gebruik zijn, bij die melding moet je dan op “no” of cancel drukken. En de andere melding is, of je zeker bent dat je een bepaalde file wilt weggooien. Als je die melding krijgt kun je wel op okee drukken omdat je dan zeker weet dat die file of regions van die file niet in de sessie gebruikt worden. Let wel op, bij delete worden lange files dus wel fysiek van de harddisk gewist. Dus let op dat je in je sessie geen verwijzingen hebt staan van files uit andere sessies, anders wis je die ook! Als je hier niet zeker van bent is het slim om voordat je deze handelingen doet eerst een “save copy as” van de sessie te maken en daarbij alle audio mee te kopieren (dat is een checkboxje wat je aan moet vinken! “save copy as” vind je in het file menu). Hierna weet je zeker dat al je audio in de audio files folder staat, wat meestal het geval is, maar niet altijd als je bijvoorbeeld veel audio imports hebt gedaan en daarbij de audio gerefered hebt ipv gekopieerd (da’s weer een optie bij “import audio”).

Hierna kan het dus nog voorkomen dat je sessie erg groot is als je compact selected tussentijds niet hebt gebruikt (dat doe ik eigenlijk ook nooit). Het is wel handig om dit aan het eind van je opschoon sessie te doen. Hiermee maak je je sessie ook voor backup een stuk compacter. Dus nadat je alle unused files hebt weggegooid druk je op select/“all regions” en dan op compact. Dit kan wel even duren, maar PT gooit nu alle gedeeltes weg die niet in je sessie gebruikt worden.

Je moet begrijpen dat in PT als je in opname gaat telkens een nieuwe file geschreven wordt. Behalve als je inprikt in destructive mode, wanneer je inprikt op een eerder opgenomen file dan overschrijft hij het gedeelte waar je inprikt. Dit gebeurt niet wanneer je een edit hebt gemaakt in de file waar je over inprikt! Verder moet je er rekening mee houden dat wanneer je inprikt met de quickpunch mode je feitelijk al opneemt op het moment dat je op play drukt. Dus als je op play drukt iets verder in opname gaat, dan heb je aan het begin van de file een “handle”, soms handig wanneer je niet helemaal zeker bent over een prik, zodoende kun je naderhand de prik wat netter maken, misschien wel dmv een crossfade. Destructive mode zou ik in principe nooit gebruiken. Da’s meer om final mixen in Pro Tools op te nemen, ipv de normale bounce to disk mogelijkheid.

Consolidate zoals eerder aangegeven is een ander optie. Als heel zeker bent dat al je edits goed zijn, dan kun je op een track of meerdere een selectie maken en daarvan dan een nieuwe file laten renderen. Hierna kun je als dit goed gegaan is de oude files weggooien. Maar dan moet je dus wel zeker zijn dat alle “priks” en edits goed zijn. Het maakt niet uit of je tracks een voor een of tegelijk consolideert! Het enige verschil is dat je het in en uit punt van je selectie niet per track kunt laten verschillen en dus stile meerendert, dit maakt niet uit, maar soms krijg je hierdoor wel langere files. Waar dat niet nodig is.

Als je dit eerst wilt proberen zonder fouten te maken is het handig als je dus eerst een “save copy as” maakt en daarbij moet je dan niet vergeten copy all audio aan te vinken, in het dialoog boxje wat je dan krijgt. Bij al deze handelingen moet je echt weten waar je mee bezig bent om niet per ongeluk iets weg te gooien. Ook is het zo dat als je meer versies van een mix gesaved hebt en je hebt in een van die sessies compact gebruikt dan kloppen je andere mixsessies van hetzelfde nummer niet meer!!! Ik denk dat dat sowieso het proberen waard als je sessie onhandelbaar is.

In principe is consolideren en daarna alle andere files weggooien het meest efficient. Als je sessie dan nog niet af te spelen is dan heb je mogelijk teveel plugins gebruikt, waardoor je processor het niet meer trekt. Het kan zo zijn dat dit eerder wel het geval was, maar plotseling niet meer. Dit is meestal zo als je echt de max van je processor benut hebt in een mix. Veel edits of regions is niet efficient, maar maakt meestal niet zoveel uit!!!

De enige optie die je dan hebt is het renderen van sommige tracks met effecten. Van de meeste plugins heb als het goed is ook een audiosuite versie. Wat je kunt doen is dan de plugin in je mixer selecteren. Bij het pulldown menu kiezen voor copy settings. Hierna naar de audiosuite versie van dezelfde plugin gaan en dan kiezen paste settings. Alle regions in de te processen track selecteren en dan op process drukken. De plugin op het kanaal van de mixer kun je nu inactive maken doorop op ctrl-apple te drukken en de plugin in de mixer aan te klikken. Hierdoor krijg je de CPU power weer terug, maar kun je altijd nog de settings terughalen wanneer je iets wilt veranderen (weer activeren gaat hetzelfde). In principe kun je het consolideren dan ook overslaan want als default zal deze handeling nu sowieso gebeuren. Het is misschien handig als je hiervoor ook even onderzoek doet naar de duplicate playlist functie, dit is handig omdat je dan een versie van je track onbewerkt kunt laten en daarboven dan een bewerkte playlist altijd handig als je een stap terug wilt doen met je effecten.

[quote:2a1d8637aa] Veel edits of regions is niet efficient, maar maakt meestal niet zoveel uit! [/quote:2a1d8637aa]

Dus als je consolideert en het helpt niet, ga dan niet door alle moeite die ik beschreven over het “opschonen” dit is wel handig maar zal niet helpen! Het is echter wel een goede beschrijving van de filehuishouding in PT.

Bedankt voor je uitvoerige en bruikbare uitleg. Was hier door de grote hoeveelheid info (en gedoe met extra software) nog niet eens aan toegekomen. Mede doordat de handleiding Engelstalig is. Doorgaans heb ik zeker geen moeite met Engels, maar als het in technisch vakjargon is wordt het op een gegeven moment een te grote kluif. Ook in het Nederlands trouwens. Toch teveel een Alpha mens waarschijnlijk :wink:

Heb inmiddels opgeschoond, maar het blijft zoals je al aangaf (super)traag. Zal ook nog de andere tips ten uitvoer brengen.

Groet,

André.

Het is zeer de vraag of je een sessie niet meer kunt afspelen door teveel edits, de hoeveelheid edits en het aantal regions dat daar uit voortvloeit is is zelden een oorzaak van vertraging en eigenlijk nooit de oorzaak van het niet willen afspelen van een sessie. Overigens wordt edit informatie wordt niet in audiobestanden bewaard, maar in het sessiedocument. Het regelmatig opschonen van de regionlist op ongebruikte regions elimineert de toch al kleine kans dat PT trager wordt door een groot aantal regions. (dan hebben we het wel over enorme aantallen...)

Ik zit te denken aan 2 mogelijke oorzaken:

  1. traagheid van de harddisk of fragmentatie;
    Door veel in te prikken zijn zoveel nieuwe files aangemaakt dat door fragmentatie en/of de traagheid van de HD een sessie niet meer goed is af te spelen; er moet te vaak een ander audiobestand gezocht en gelezen worden.
    Vreemd is dat je er geen melding van krijgt; PT’s DAE geeft normaal gesproken een waarschuwing voor deze 2 situaties …(iets in de trant van disk too slow of disk too fragmented)
    oplossing: sporen waarvan je zeker weet dat ze goed zijn consolideren en het bronmateriaal verwijderen.
    Consolideren per spoor kan dmv dupliceren of een bounce to disk waarbij alleen het te consolideren kanaal niet op mute staat.
    (dupliceren neemt plugins en automation niet mee, bouncen wel)
    Hoe je bronmateriaal verwijderd heeft GvdB uitgebreid beschreven.
    (b.v. met shift-apeltje-u/shift appeltje B)
    Consolideren inclusief effekten d.m.v. audiosuite plugins zou ik nooit doen; er is geen weg meer terug… automatisering en effekt-plugin’s zou ik zo lang mogelijk toegankelijk houden.
    Het vergroten van de diskbuffer-size kan helpen, maar vertraagt het werken met PT behoorlijk;
    de buffers moeten iedere keer opnieuw gevuld worden. Ik zou nooit een maximale setting kiezen.
    De fabriekssetting voldoet m.i. goed; en goede balans tussen buffer en snelheid.

  2. het aantal plugins; dit zijn namelijk de echte CPU-vreters.
    Draai je in de genoemde sessies veel plugins?
    Het bypassen van plugins heeft geen invloed op de cpu-belasting; je moet ze verwijderen of inactief maken dmv control/appeltje op de insert waar een plugin in staat.

succes, bart

Die meldingen komen me niet onbekend voor, Bart. Heb ze geloof ik eerder genegeerd, maar nu breekt het me kennelijk op.

Het leek weer goed te gaan, maar ondertussen krijg ik na bouncing, voorafgaand aan het converteren, de volgende melding:

[i:1d679a8516]Could not complete the “bounce to disk” command because: assertion in ff audio property.ccp, line 33.[/i:1d679a8516]

Het is mogelijk dat je PT sessie corrupt is. Wat je dan zou kunnen doen, een nieuwe lege sessie aanmaken en hierin alle tracks van je andere sessie importeren. Hierbij hoef je de audio enkel te referen en niet fysiek te kopieren, dus dit gaat heel snel. Hiermee krijg je ook je mix terug, want alle mixerdata en automation wordt meegekopieerd.

En bart, wat ik bedoelde is niet dat je een track definitief moet processen, maar je kunt van je track een duplicate playlist aanmaken en die processen. Je kunt dan altijd de ongeprocessede playlist terughalen. En als je de plugins dan inactive op de inserts van de mixer laat zitten dan kun je altijd precies achterhalen wat je gedaan hebt en wat je eventueel wilt veranderen als je het later anders wilt. Op deze manier is het mogelijk om veel meer plugins te gebruiken. Je hoeft echt niet alle tracks te processen, maar een paar kan al een hoop schelen in CPU kracht. En als je dit via de audiosuite plugins doet gaat het sneller dan realtime, dan hoef je dus niet een heel nummer af te wachten.

Ik ben het helemaal eens dat veel edits meestal niet leiden tot tragere sessies. Maar het is zeker wel van invloed. Ik kan me een geval herinneren van zo’n 24 tracks drums vol met edits, en dat wilde op een ander systeem echt niet meer afspelen. Na het consolideren ging dat weer wel. Maar wat ik hieruit op kan maken is dat niet echt het probleem.

Welke versie van PT draai jij? En welke audio driver? En welke interface? Hoeveel tracks en hoeveel plugins heb je draaien en ook wat voor Mac is het?

De melding die je krijgt heb ik ook wel eens gehad, maar dat had toen met het vrijmaken van CPU power te maken. Is het ook zo dat als je op play drukt dat op bepaalde momenten je sessie ook een foutmelding geeft. Dan is het logisch dat ie de bounce ook niet wil voltooien. Ik zou gewoon wat tracks processen. (check die playlist features, zodat je altijd een stap terug kunt doen!)

Dit zijn van die momenten dat ik denk 'ben ik daar muzikant voor geworden?!' :lol: (Nou ja, zo'n beetje nog). Maar ik ga weer aan de slag mannen! Jullie horen de uitkomst binnenkort.

Voor mijn Mac, zie onderschrift. M-Box, Pro Tools 6.4, Digi CoreAudio Manager.

In de bewuste session heb ik 10 tracks openstaan. Daarbij heb ik 16 plugins draaien.

Ik denk dat ik het heb gevonden aan de hand van de errormelding:

De fadefiles in de sessie zijn waarschijnlijk corrupt.
Om daar vanaf te komen gooi je alle fadefiles die in de fades-map zitten weg.
Als je nu de sessie weer opnieuw opstart zal PT alle fadefiles opnieuw aanmaken.
De fades en crossfades (lengte en vorm) zijn omschreven in het PT-sessiedocument, bij het opnieuw aanmaken krijg je dus exact dezelfde fades terug.
Fadefils kun je altijd zonder risico weggooien, ze komen vanzelf weer terug.

overigens kunnen grote aantallen fades en crossfades je systeem wel belasten;
PT rekent ze niet real-time uit, maar maakt kleine audiobestanden van je fades.
Als je erg veel fades hebt gemaakt komt de fragmentatie/traagheid van de HD om de hoek kijken…

Een kopie maken had ik al eens gedaan, maar de assertion nr. 33 fout(melding) bleef aanwezig. Fade files mocht ook niet baten, maar inmiddels is het na consolideren en wat verder aanklooien, alsnog gelukt! Het leek er op dat ie de session weer niet kon converteren, maar met wat hangen en wurgen ging dat dus!

Maakt het nog wat uit of je in wav bounced? Dit raadde iemand mij ook nog aan. Doe het nu in aiff, stereo interleaved, 16 bits.

[quote:9074c5c933="andrez"]Maakt het nog wat uit of je in wav bounced? Dit raadde iemand mij ook nog aan. Doe het nu in aiff, stereo interleaved, 16 bits.[/quote:9074c5c933]

Nee, dat maakt niets uit.
Tenzij je het anders hebt ingesteld gebruikt PT voor sessies zijn eigen audioformaat: SD2.
Bouncen gaat standaard ook in SD2. Als je AIFF of wav als eindformaat kiest,
wordt na de bounce het SD2 bestand naar AIFF of wav geconverteerd.

over de assertion nr. 33-foutmelding:
de ProTools-answerbase geeft o.a. corrupte fades op als mogelijke oorzaak vd error.
Andere gesuggereerde oplossing; wordt bouncen niet voltooid, dan kan het vergroten/verkleinen van de gemaakte selektie en dan opnieuw bouncen helpen.

Je vind de answerbase op digidesign’s webstek>support>answerbase

Merkwaardig dat het weggooien ervan dan niets uit leek te maken. Maar goed, het is dan ook een [i:7e23c77b0e]mogelijke[/i:7e23c77b0e] oorzaak.