slechte communicatie tss Intel macs en software installers?

Ik heb hier op 2 dagen al drie keer meegemaakt dat ik bepaalde software niet kan installeren op mn Intel iMac omdat de installer zegt dat de computer niet aan de vereisten voldoet. De installer van Divx 6 zegt bvb dat ik minstens met systeem 10.3 moet werken (ik zit op 10.4.4, duh) en die Flip4Mac zegt dat ik minstens Quicktime 6.5.3 of zo moet hebben (heb 7.0.4)!?

Loopt er nog wat mis met de communicatie of ligt dit aan de betreffende installers? Blijft het dan voor sommige software toch wachten op een Universal Binary voor we ze kunnen gebruiken op Intel?

Voor divx is een beta voor de Intel Mac uit, die installeert gewoon goed en draait ook stukken sneller dan de PPC versie. Flip4mac werkt idd niet, daarvoor moet elk moment een Intel versie voor worden vrijgegeven.