Twee thema's RapidWeaver lukt maar half

Ik heb deze vraag gisteren al gesteld, maar ik kom er nog steeds niet uit.

Ik heb twee eenvoudige, maar verschillende sites gemaakt met RapidWeaver: A en B. Beide hebben een verschillend theme, maar als ik eerst B (illustraties) aanklik en vervolgens de link info>plaatje neem, dan verschijnt site A (dierenkliniek) met het vorige thema. De volgende links op diezelfde pagina zijn wel het juiste thema. Ik hoop dat jullie het nog volgen.

Bovendien komt bij site A (dierenkliniek) tekst en foto’s links, terwijl ik dat juist zoals bij de volgende pagina’s van die site rechts wil hebben. ???

Wanneer ik voor beide sites hetzelfde thema neem, is er geen vuiltje aan de lucht.

Hoe lukt het me om beide pagina’s elk met hun eigen thema te laten zien? Of is dat alleen mogelijk als ik over en weer geen links naar de pagina’s maak?

Ik weet natuurlijk niet hoe je werkt, en hoe je een nieuw project opstart, maar volgens mij zet je een aantal dingen door elkaar ;)

  • Elke site zet je in een nieuwe map (voorkomt rommel ook, hehe)
  • Als ik me goed kan herinneren, en dat valt nog wel eens tegen, dan zou je
    in Rapidweaver “make/create new project” moeten kunnen kiezen.
    Dat zou ervoor moeten zorgen dat dingen niet door elkaar gaan lopen.

Als dit niet helpt, dan zou je de voorkeuren eens kunnen weggooien; misschien dat dat helpt.
Verder zou ik 't even niet weten… maar ik heb zo’n vermoeden dat je zelf iets niet
helemaal goed doet, of over het hoofd ziet. Ik heb zelf een poosje met Rapidweaver gewerkt,
maar heb dit soort dingen nog nooit gezien namelijk :slight_smile:

Succes in ieder geval!

  • Joram

ps.: voor het linken naar andere rapidweaversites kun je het best gewoon zorgen dat de websites
in aparte mappen staan, en dan de link aangeven van de betreffende pagina, dus zoals:

[code:1:6e034752fa]<a href="http://www.site.nl/mapje/pagina.html>linkje naar andere site</a>[/code:1:6e034752fa]
of

[code:1:6e034752fa]<a href="/map/pagina.html>linkje naar andere site</a>[/code:1:6e034752fa]

Bedankt alvast voor de tips. Vanavond ga ik er aan werken (heb nu even geen tijd).

Beide sites staan gescheiden van elkaar in aparte mappen (die ontstaat na ‘Export Site’).
Elke site upload ik via het menu in RW: 'Publish Site".
Misschien dat er dan conflicten ontstaan?

Of moet ik de bestanden verwijderen met bv. Transmit en dan de gesloten map van elke site uploaden met Transmit?

Je moet natuurlijk wel zorgen dat het indexbestand van de website losstaat. Als je de map in zijn geheel uload, dan kan de server niet zien waar het "index.html" staat, en dus ook de website niet laden (kan wel, maar vergt wat meer kennis).

Hoe dat met 2 websites op 1 server uploaden zit weet ik niet, maar je moet er altijd
rekening mee houden dat de server/het web altijd zoekt naar een index.html, en niet
zomaar in mapjes kan kijken :wink:

Mvg,
Joram

Map A bevat een index.html-bestand en daarnaast nog een serie mappen met o.a. page1.html, page2.html, enzovoorts. Map B bevat een illust.html-bestand met idem ook een serie sub-mapjes met page.html-bestanden.

Wanneer ik dus index.html en illust.html upload en daarnaast de rest van de map in zijn geheel (dus gesloten), zou het ook moeten lukken? Of moeten de page.html-bestanden ook één voor één worden geupload?

Toch raar overigens, wanneer ik vanuit RW de beide sites publish, de zaak niet vanzelf in orde komt?

Misschien een bugje in RW :) Die "illust.html" gaat het internet (iemand die je site zoekt) dus niet zomaar zien, tenzij je er een url aanhangt.

Als je op 1 webruimte 2 sites wilt hosten, dan kun je inderdaad bijvoorbeeld het volgende doen;

  • site 1:
    zoals je zegt, de index.html loszetten. Daar dan een url aanhangen (www.naam.nl)
  • site 2:
    die illust.html kun je ook zo uploaden, maar dan moet je die denk ik zo aanwijzen dat
    hij via de url te zien is… www.naam2.nl of www.naam.nl/illust.html ?

Het is een beetje lastig uitleggen :oops:

[quote:6c0045869d="joram"]zoals je zegt, de index.html loszetten. Daar dan een url aanhangen (www.naam.nl) - site 2:[/quote:6c0045869d]

Bedankt voor de uitgebreide antwoorden, joram.
Hoe hang ik een url aan index.html?

Joram, bedankt. Het is allemaal gelukt. Ik had beide sites inderdaad niet in twee verschillende mappen.