update van osx 10.2.1 naar 10.2.5 lukt niet

Ik probeer dus de 10.2.5 update te installeren maar krijg steeds de melding dat er iets fout gaat :( Dit is de logfile: [code:1:38a17c26aa] Mac OS X-update Installation Log Target Selection _volumeAppeared: Adding volume Macintosh HD deactivate: removing all cells from _volumeMatrix Selected volume "Macintosh HD" Mounted at: / OpenFirmware: mac-io/ata-4@1f000/@0:5 Partition type: HFS+ Partition map: disk0s5 Partition: 5 Protocol: ATA Media Type: Generic Volume Size: 30002733056 Error detected Name: NSRangeException Reason: *** -[NSCFArray objectAtIndex:]: index (0) beyond bounds (0)

Completed installation steps:
0:I 0.000053:setPhaseAndNotify:2 message:nil object package:Mac OS X-update 
1:I 0.000053:initBoms 
2:I 0.000053:setStatusStringAndNotify:Finding moved files 
3:I 0.000053:_resolveFindFilesPaths:Mac OS X-update 
4:T 0.016667:/Users/chris/Desktop/MacOSXUpdateCombo10.2.5.pkg/Contents/Resources/preflight /Users/chris/Desktop/MacOSXUpdateCombo10.2.5.pkg / / /
5:I 0.000053:setStatusStringAndNotify:Pakketinhoud wordt gecontroleerd 
6:I 0.007615:setPhaseAndNotify:2 message:nil object package:Mac OS X-update 
7:I 0.007615:prepareBomForPackage:Mac OS X-update 
8:I 0.000053:setPhaseAndNotify:2 message:nil object package:Mac OS X-update 
9:I 0.000053:createTempFolder:/tmp/.MacOSXUpdateCombo10.2.5.pkg.381.install 
10:I 0.000053:createTempReceiptFolder 
11:I 0.000053:setStatusStringAndNotify:Installatie wordt geconfigureerd 
12:I 0.000053:enableBundleVersioning 
13:I 0.007615:setPhaseAndNotify:2 message:nil object package:Mac OS X-update 

Remaining installation steps:
0:I 0.007615:writeConfigFilesForPackage:Mac OS X-update 
1:I 0.000053:setPhaseAndNotify:2 message:nil object package:Mac OS X-update 
2:I 0.000053:releaseInstalledBom 
3:I 0.007615:setPhaseAndNotify:3 message:nil object package:Mac OS X-update 
4:I 0.007615:makePackageDestRoot:/ 
5:I 0.850000:extractFilesFromPackage:Mac OS X-update withPaths:/tmp/.MacOSXUpdateCombo10.2.5.pkg.381.install/MacOSXUpdateCombo10.2.5.pkg/normal/extract toDestinationPath:nil object 
6:I 0.000053:setStatusStringAndNotify:Afsluitend script wordt uitgevoerd 
7:T 0.016667:/Users/chris/Desktop/MacOSXUpdateCombo10.2.5.pkg/Contents/Resources/postinstall /Users/chris/Desktop/MacOSXUpdateCombo10.2.5.pkg / / /
8:I 0.007615:Pakketontvangstbewijs wordt geschreven:writeReceiptForPackage:Mac OS X-update 
9:I 0.000053:setPhaseAndNotify:3 message:nil object package:Mac OS X-update 
10:I 0.000053:setStatusStringAndNotify:Installatie wordt voltooid 
11:I 0.007615:fixupResourceForks 
12:I 0.007615:registerApps 
13:I 0.007615:_touchModDates 
14:I 0.000053:setStatusStringAndNotify:Afsluitend script wordt uitgevoerd 
15:T 0.016667:/Users/chris/Desktop/MacOSXUpdateCombo10.2.5.pkg/Contents/Resources/postflight /Users/chris/Desktop/MacOSXUpdateCombo10.2.5.pkg / / /
16:I 0.007615:removeTempFolder 
17:I 0.000053:setPhaseAndNotify:4 message:nil object package:nil object 
18:I 0.000053:setStatusStringAndNotify: 
19:I 0.007615:runPrebinding 
20:I 0.000053:setStatusStringAndNotify: 
21:I 0.007615:setSuccess 
Install Failed
Error detected
Name: NSGenericException
Reason: *** -[NSCFArray objectAtIndex:]: index (0) beyond bounds (0)

[/code:1:38a17c26aa]
kan iemand me verder helpen?

Misschien iets fout gegaan met het downloaden, probeer 10.2.5 anders nog een keer te downloaden of doe het in stappen. Eerst nog 10.2.3 of 10.2.4 ervoor instaleren. Verder had ik 10.2.5 niet geinstaleerd, ik vind 10.2.4 beter werken!

Dennis

Heb je wel de combo-update gebruikt ipv de gewone update? Met de combo kan je van 10.2.1 naar 10.2.5 maar met de gewone update alleen van 10.2.4 naar 10.2.5.

[quote:b9c698fcbc="Zodiack"]Heb je wel de combo-update gebruikt ipv de gewone update? Met de combo kan je van 10.2.1 naar 10.2.5 maar met de gewone update alleen van 10.2.4 naar 10.2.5.[/quote:b9c698fcbc]

Ik heb de combo 10.2.4 en 10.2.5 geprobeerd maar beide werken niet.
Het werkt ook niet als ik ze probeer te installeren met een andere user en opnieuw downloaden lost het ook niet op…

ik ga mijn homedir backuppen en dan probeer ik het nog eens na een schone installatie.

[quote:7b1c98c9f9] Ik heb de combo 10.2.4 en 10.2.5 geprobeerd maar beide werken niet. Het werkt ook niet als ik ze probeer te installeren met een andere user en opnieuw downloaden lost het ook niet op...[/quote:7b1c98c9f9] Vreemd, ik denk dat je maar even moet wachten op tips van anderen die veel meer kennis hebben, succes.

Al een poging gedaan om te updaten via softwareupdate????

[quote:b2844c6d86="digitalguru"]Al een poging gedaan om te updaten via softwareupdate????[/quote:b2844c6d86]

Dat was het eerste dat ik heb geprobeerd, zelfde probleem.

Ik heb osx volledig opniew geinstalleerd (os9 heb ik niet meer geinstalleerd), alle updates zijn net geinstalleerd en hij is nu bezig met ‘optimaliseren’.

edit: de update is gelukt :slight_smile:

het logbestand begint met een melding van een disk/partitiefout; het probleem zit dus niet in de updates, maar in de disk/partitie waarop je ilt installeren. Haal DiskWarrior er eens overheen om evt partitie of diskproblemen op te lossen, en als dat niet helpt zou ik een volledige reformat met "nullen schrijven" overwegen.