Waarom kan ik niet installeren met NPM?

 

Wat een fucking gedoe altijd met dat Terminal geneuk. ?

Misschien ff sudo proberen?

Of ergens anders de zaken laten neerzetten:

 

https://johnpapa.net/node-and-npm-without-sudo/

Stel ik zou Node en NPM weer proberen te verwijderen - wat qua plezier gelijk staat aan bij je schoonmoeder op bezoek gaan. En daarna zou ik deze dingen installeren via Homebrew, krijg ik dat ook hetzelfde gezeur of niet omdat het in Brew geïnstalleerd wordt?

 

En veel belangrijker, moet je dan altijd eerst het brew commando typen voordat je npm kunt gebruiken of kun je dan ook gewoon npm Install pakketje en doe je ding typen.

 

Ik heb node en npm gewoon op de standaard manier geinstalleerd (zonder Homebrew). Dat werkt prima.

 

Ik gebruik npm om React Redux apps mee te maken.

 

Dat heb ik ook gedaan, via de Node.js website maar dan direct op de homepage. Linkse optie LTS (for most people) .pkg downloaden en dan gewoon installeren door op OK, OK, OK te drukken. Geen aanpassingen of zoiets. Toch krijg ik dat irritante gedoe met niet de juiste rechten hebben wanneer ik iets wil installeren.

 

Ik ben potverdorie gewoon ingelogd als Admin. Ik heb maar één account op mijn computer. :slightly_frowning_face:

 

 

Maar heb je ‘sudo’ gebruikt?

 

sudo npm install -g lighthouse

Dat lukte ook al niet, dat was het eerste dat ik online vond.

 

Mijn vingers jeuken om met een FTP app die folder(s) op te zoeken en dan de CHMOD rechten te veranderen, maar dan ga je dingen doen waar je echt niet aan moet beginnen. Da’s je huis proberen te voegen met een breekijzer.

 

https://docs.npmjs.com/resolving-eacces-permissions-errors-when-installing-packages-globally

en

https://docs.npmjs.com/downloading-and-installing-node-js-and-npm

Is dit geen gevalletje ‘disable SIP’?

Het is gelukt. Al heb ik geen idee wat ik nu gedaan heb. ?

 

Door npm test te runnen kwam ik er ook achter dat ik geen package.json bestand meer had in de Home folder. En dat klopt, die had ik ooit weggegooid omdat ik dacht dat deze van Composer was.

 

Nu werkt het wel en kan ik mijn testjes uitvoeren.

 

Bedankt voor het meedenken. ?

Als je met ‘chown -R’ alle entries in /usr/local even van jezelf maakt werkt het wel.

Met sudo is niet echt de goede weg ?