webserver wel toegankelijk onder mac, niet onder win....?

Hi,

Ik draai op m’n iMac een simpel Apache webservertje (en webcam).

Nu is het zo dat die door andere Mac-gebruikers gewoon te benaderen
is, maar windows gebruikers krijgen de standaard Explorer:
“page not found”-error (niet de Apache 404 error).

Ik weet niet of het uitmaakt dat ik Weblock (pref. panel) gebruik
voor users en passes, want hij vind de server niet eens…

Iemand een idee?

Is dat op een intern netwerk? Of vanaf internet (die windows pc's)?

Werkt een simpele test pagina wel (bijv. alleen een tekst)?

Kunnen de windows pc de site wel bereiken via http://ip.ad.re.s ?

ik bedoel dus via internet, van andere lokatie...en het probleem geldt alleen voor mensen die onder windows naar mijn webserver willen. met een mac lukt t gewoon.

http://xxx.xxx.xxx.xxx/ geeft dus die error (met of zonder eind-slash)
http://xxx.xxx.xxx.xxx/~username/ geeft ook error (idem)

het maakt niet uit welk bestand (plaintext, html, etc) er in de
webservermap staat, de server wordt niet gevonden.

let wel:

http://localhost/ doet t wel op eigen machien
http://localhost/~username/ doet t ook op eigen machien

dus de webserver draait wel goed verder…alleen voor mac?:slight_smile:

hehehe…idee?

[quote:3c8ce3ace5="lampje"]http://xxx.xxx.xxx.xxx/ geeft dus die error (met of zonder eind-slash) http://xxx.xxx.xxx.xxx/~username/ geeft ook error (idem) [/quote:3c8ce3ace5]

Praat eens met je internet provider. Mag je wel een server draaien thuis? Wat voor aansluiting heb je? Als je bv ADSL hebt, staan de instellingen op je router goed om een server te draaien?

Jan

Ik had een soort gelijk probleem. Bij mij was het probleem dat ik twee servers tegelijk over poort 80 liet lopen terwijl ik dat niet in de gaten had. Na een herstart was de tweede server uitgeschakeld en deed alles het weer. Mijn systeem gaf niet helemaal dezelfde symptomen maar misschien moet je in die hoek je probleem zoeken.... Succes.

[quote:0520ed0eba="JanWeijers"]Praat eens met je internet provider. Mag je wel een server draaien thuis? Wat voor aansluiting heb je? Als je bv ADSL hebt, staan de instellingen op je router goed om een server te draaien?

Jan[/quote:0520ed0eba]
Ik had eenzelfde probleem en heb een ander poortnummer ingesteld waarnaar de webserver luistert. (Kan heel makkelijk met Webmin) Je zet dat poortnummer vervolgens met een : achter het IP nummer, dus http://xxx.xxx.xxx.xxx:poortnummer.

nee kijk,...alles deed t gewoon.....alleen sinds jag niet meer...ofzo..

ik had 1 machine als webserver, stond in de modem goed geport,
(ik draai xs4all-ADSL) en het werkte gewoon…

maar van de ene dag op de andere (of week, ik gebruik de server
niet echt veel…afentoe), pats boem deed ie t niet meer vanaf
een win-machien…

maaarre, ik doe t nu toch al anders (meerdere machines aan modem,
andere machien als webserver, andere NATs in modem gezet, etc…)

die webcam ga ik ook anders doen…:slight_smile:

maandag ff chekke of ie vanaf mn werk weer bereikbaar is…

blijft raar, maar misschen heb ik OSX op die iMac gewoon verwoest… :slight_smile:

thnx voor t meedenken,
ik laat nog wel ff weten hoe t afgelopen is