Wordpress krijg ik niet aan de praat

Ik krijg de volgende melding na installatie van Wordpress (heb Wordpress vaker probleemloos installeert):

Error establishing a database connection

Mijn provider (Webreus) geeft niet thuis. Ik heb alle gegevens gecontroleerd (Config.php) maar hij pakt het niet.

Heeft iemand dezelfde ervaring en misschien een idee wat ik fout doe? Of zijn het server instellingen?

Bedankt voor alle reacties.

Kloppen de naam van de database, de gebruikersnaam voor de database, enz. wel?

Loop hier eens doorheen:
http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-error-establishing-a-database-connection-in-wordpress/

Het zijn je gegevens die niet kloppen, waarschijnlijk een tikfout tijdens het invoeren van de database-naam - gebruikersnaam of wachtwoord.

Wat ook wel eens wil helpen is om zelf eerst de database aan te maken, daarna pas Wordpress te installeren.
Het kan zijn dat je provider de boel wat strakker heeft gezet, omdat een installatie vraagt om toegang tot mysql om de database aan te kunnen maken.

Wat polansky zeg kan goed kloppen. ik zou zoiezo al de database zelf aanmaken.

Ja, ik heb eerst de database aangemaakt en toen Wordpress geinstalleerd met het aangepaste Config bestand. De naam en password voor MySQL heb ik vervolgens geknipt en geplakt om zeker te weten dat het goed is. Typefoutje is snel gemaakt.

Maar bedankt. Ik zal de link van NeXT even doorlezen.

Ik ga gewoon even een nieuwe database aanmaken, kijken of dat helpt.

Nieuwe database aangemaakt. Niet geholpen. Nu de nederlandse versie van Wordpress geïnstalleerd.

Ga ik naar: www.domeinnaam.nl/wp-admin en krijg ik deze melding:

[i]Error occurred: 403 - forbidden

Apache Server at: s1000493-958.mijnreus.nl[/i]

Heb jij php 5.3. of php 5.4 op de server.

<?php
phpinfo();
?>

5.3

Maar ik heb een mailtje ontvangen van Webreus. Morgen eens kijken of ik daar de oplossing uit kan halen.

Wordpress maakt zelf geen database aan, geen enkel php script heeft toegang tot dergelijke sql statements, mits je daar zelf uiteraard toestemming tot hebt gegeven in je ini.

Kom er niet uit.

Op de server in de map httpdoc, staat een mapje ‘domeinaam.nl’. Daarin zou Wordpress geinstalleert moeten worden. Ik heb daar ook mijn vraagtekens bij. Maar goed, ik wil toch naar een provider toe die je kunt bellen. Vind ik toch handiger.

Hey Olbo.

Ik heb zelf ook een website runnen via Webreus. Eentje over iPhone onderdelen. Ik heb dit probleem ook gehad met Webreus. Wat ik toen heb gedaan is ALLES verwijderen. Even opnieuw WP downloaden http://nl.wordpress.org/wordpress-3.6.1-nl_NL.zip en deze op je server installeren via het Dashbord.

Nu heb je weer een clean setup. Vervolgens kan je op de Pleskdeks (iod) van webreus of op de website ( een van de twee) het bestandje htacces synchroniseren. Doe dit even, bij mij heeft dit geholpen. Succes!

Dankje. Ik ga het nog eens proberen. Hopelijk werkt het.

Thanks again :wink:

En… kom je er al uit? Zo niet laat het me even weten. Ben bereid je te helpen. Succes!

@olbo,

Controleer eens in je WebReus settings of PHP safe_mode UIT staat.
Normaal moet deze standaard uit staan maar je weet maar nooit natuurlijk.

dit heb ik toen ook nagevraagd bij WebReus. Deze staat standaard uit.

Dit kreeg ik als reply op mijn email destijds.

Beste heer,

Safe mode staat (behalve op reeds lang bestaande pakketten) op onze hostingpakketten standaard uit.
Het de-activeren van safemode zoals beschikbaar in onze klantenlogin is alleen bruikbaar voor de eerder genoemde oudere hostingpakketten.

Dit geld dus ook voor uw domein
Met vriendelijke groet,

Ton v R.
WebReus

ik vind niet netjes om zijn volledige naam open en bloot op internet te zetten.
En daarbij word hier al 2 keer sluip spam gebruikt.

Je bent ook pas 6 uur lid, dus het lijkt wel alsof je gezocht heb naar topic om je website te promoten…

[quote=MEEUW url=http://www.onemorething.nl/community/topic/wordpress-krijg-ik-niet-aan-de-praat/#post-2603696 time=1380727873]ik vind niet netjes om zijn volledige naam open en bloot op internet te zetten.
En daarbij word hier al 2 keer sluip spam gebruikt.

[/quote]

Ik probeer gewoon iemand te helpen die dezelfde problemen heeft gehad als mij. De problemen heb ik via boven beschreven manier opgelost en zo probeer ik een mede-internetter te helpen.