wxMac 2.4 compilen onder OS X 10.2.6 met GCC 3.3 geeft error

Hai, Ik zou graag wxMac 2.4.0 of 2.4.1 willen installeren, maar als ik beide versies probeer te compilen met make, geven ze de error: [code:1:2bf68edc4f]../src/mac/dc.cpp:1742: error: non-lvalue in unary `&' make: *** [dc.o] Error 1[/code:1:2bf68edc4f] 2.4.0 geeft als regelnummer 1667 aan en 2.4.1 1742. De betreffende regelnummer in dc.o is: [code:1:2bf68edc4f]status = ::ATSUCreateStyle(&(ATSUStyle)m_macATSUIStyle) ;[/code:1:2bf68edc4f] In beide versies is deze gelijk.

Ik compile met GCC 3.3 (die van de developer tools met de update van de Developer Connection site gehaald).

Misschien klopt er het een en ander niet aan mijn schrijven, maar dat komt omdat ik pas sinds een halve week op een Unix variant werk na 10 jaar Windows gebruiken :lol:

Uiteindelijk bleken het 3 verkeerde files te zijn. Die heb ik maar uit de CVS te gehaald en nu is hij dus ook GCC 3.3 compatible. Nu heb ik ook een ander probleem:

Waar staat de config file ‘wx-config’?

Ik wil namelijk xMule installeren.

cd / find . -name wx-config -print | grep config

Levert dat iets op?